Discover Government News


   SUSE Security Update: Security update for libksba
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3681-1
Rating:             critical
References:         #1204357 
Cross-References:   CVE-2022-3515
CVSS scores:
                    CVE-2022-3515 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libksba fixes the following issues:

     - CVE-2022-3515: Fixed a possible overflow in the TLV parser
       (bsc#1204357).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3681=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3681=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3681=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3681=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3681=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3681=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3681=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3681=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1

   - SUSE OpenStack Cloud 9 (x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba-devel-1.3.0-24.3.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      libksba-debugsource-1.3.0-24.3.1
      libksba8-1.3.0-24.3.1
      libksba8-debuginfo-1.3.0-24.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-3515.html
   https://bugzilla.suse.com/1204357

SUSE: 2022:3681-1 critical: libksba

October 21, 2022
An update that fixes one vulnerability is now available

Summary

This update for libksba fixes the following issues: - CVE-2022-3515: Fixed a possible overflow in the TLV parser (bsc#1204357). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3681=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3681=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3681=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3681=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3681=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3681=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3681=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3681=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1 - SUSE OpenStack Cloud 9 (x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): libksba-debugsource-1.3.0-24.3.1 libksba-devel-1.3.0-24.3.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): libksba-debugsource-1.3.0-24.3.1 libksba8-1.3.0-24.3.1 libksba8-debuginfo-1.3.0-24.3.1

References

#1204357

Cross- CVE-2022-3515

CVSS scores:

CVE-2022-3515 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-3515.html

https://bugzilla.suse.com/1204357

Severity
Announcement ID: SUSE-SU-2022:3681-1
Rating: critical

Related News