SUSE: 2022:3806-1 important: dbus-1 | LinuxSecurity.com

   SUSE Security Update: Security update for dbus-1
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3806-1
Rating:             important
References:         #1087072 #1204111 #1204112 #1204113 
Cross-References:   CVE-2022-42010 CVE-2022-42011 CVE-2022-42012
                   
CVSS scores:
                    CVE-2022-42010 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-42010 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
                    CVE-2022-42011 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-42011 (SUSE): 4.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L
                    CVE-2022-42012 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-42012 (SUSE): 4.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Micro 5.3
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that solves three vulnerabilities and has one
   errata is now available.

Description:

   This update for dbus-1 fixes the following issues:

     - CVE-2022-42010: Fixed potential crash that could be triggered by an
       invalid signature (bsc#1204111).
     - CVE-2022-42011: Fixed an out of bounds read caused by a fixed length
       array (bsc#1204112).
     - CVE-2022-42012: Fixed a use-after-free that could be trigged by a
       message in non-native endianness with out-of-band Unix file descriptor
       (bsc#1204113).

     Bugfixes:

     - Disable asserts (bsc#1087072).


Special Instructions and Notes:

   Please reboot the system after installing this update.

Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-3806=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-3806=1

   - SUSE Linux Enterprise Micro 5.3:

      zypper in -t patch SUSE-SLE-Micro-5.3-2022-3806=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      dbus-1-1.12.2-150400.18.5.1
      dbus-1-debuginfo-1.12.2-150400.18.5.1
      dbus-1-debugsource-1.12.2-150400.18.5.1
      dbus-1-devel-1.12.2-150400.18.5.1
      dbus-1-x11-1.12.2-150400.18.5.1
      dbus-1-x11-debuginfo-1.12.2-150400.18.5.1
      dbus-1-x11-debugsource-1.12.2-150400.18.5.1
      libdbus-1-3-1.12.2-150400.18.5.1
      libdbus-1-3-debuginfo-1.12.2-150400.18.5.1

   - openSUSE Leap 15.4 (noarch):

      dbus-1-devel-doc-1.12.2-150400.18.5.1

   - openSUSE Leap 15.4 (x86_64):

      dbus-1-32bit-debuginfo-1.12.2-150400.18.5.1
      dbus-1-devel-32bit-1.12.2-150400.18.5.1
      libdbus-1-3-32bit-1.12.2-150400.18.5.1
      libdbus-1-3-32bit-debuginfo-1.12.2-150400.18.5.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

      dbus-1-1.12.2-150400.18.5.1
      dbus-1-debuginfo-1.12.2-150400.18.5.1
      dbus-1-debugsource-1.12.2-150400.18.5.1
      dbus-1-devel-1.12.2-150400.18.5.1
      dbus-1-x11-1.12.2-150400.18.5.1
      dbus-1-x11-debuginfo-1.12.2-150400.18.5.1
      dbus-1-x11-debugsource-1.12.2-150400.18.5.1
      libdbus-1-3-1.12.2-150400.18.5.1
      libdbus-1-3-debuginfo-1.12.2-150400.18.5.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (x86_64):

      dbus-1-32bit-debuginfo-1.12.2-150400.18.5.1
      libdbus-1-3-32bit-1.12.2-150400.18.5.1
      libdbus-1-3-32bit-debuginfo-1.12.2-150400.18.5.1

   - SUSE Linux Enterprise Micro 5.3 (aarch64 s390x x86_64):

      dbus-1-1.12.2-150400.18.5.1
      dbus-1-debuginfo-1.12.2-150400.18.5.1
      dbus-1-debugsource-1.12.2-150400.18.5.1
      dbus-1-x11-1.12.2-150400.18.5.1
      dbus-1-x11-debuginfo-1.12.2-150400.18.5.1
      dbus-1-x11-debugsource-1.12.2-150400.18.5.1
      libdbus-1-3-1.12.2-150400.18.5.1
      libdbus-1-3-debuginfo-1.12.2-150400.18.5.1


References:

   https://www.suse.com/security/cve/CVE-2022-42010.html
   https://www.suse.com/security/cve/CVE-2022-42011.html
   https://www.suse.com/security/cve/CVE-2022-42012.html
   https://bugzilla.suse.com/1087072
   https://bugzilla.suse.com/1204111
   https://bugzilla.suse.com/1204112
   https://bugzilla.suse.com/1204113

SUSE: 2022:3806-1 important: dbus-1

October 27, 2022
An update that solves three vulnerabilities and has one errata is now available

Summary

This update for dbus-1 fixes the following issues: - CVE-2022-42010: Fixed potential crash that could be triggered by an invalid signature (bsc#1204111). - CVE-2022-42011: Fixed an out of bounds read caused by a fixed length array (bsc#1204112). - CVE-2022-42012: Fixed a use-after-free that could be trigged by a message in non-native endianness with out-of-band Unix file descriptor (bsc#1204113). Bugfixes: - Disable asserts (bsc#1087072).

References

#1087072 #1204111 #1204112 #1204113

Cross- CVE-2022-42010 CVE-2022-42011 CVE-2022-42012

CVSS scores:

CVE-2022-42010 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-42010 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

CVE-2022-42011 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-42011 (SUSE): 4.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L

CVE-2022-42012 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-42012 (SUSE): 4.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Micro 5.3

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-42010.html

https://www.suse.com/security/cve/CVE-2022-42011.html

https://www.suse.com/security/cve/CVE-2022-42012.html

https://bugzilla.suse.com/1087072

https://bugzilla.suse.com/1204111

https://bugzilla.suse.com/1204112

https://bugzilla.suse.com/1204113

Severity
Announcement ID: SUSE-SU-2022:3806-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.