Discover Government News


   SUSE Security Update: Security update for gstreamer-plugins-base
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3911-1
Rating:             moderate
References:         #1185448 
Cross-References:   CVE-2021-3522
CVSS scores:
                    CVE-2021-3522 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-3522 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 12-SP5
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE Linux Enterprise Workstation Extension 12-SP5
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for gstreamer-plugins-base fixes the following issues:

   - CVE-2021-3522: Fixed frame size check and potential invalid reads
     (bsc#1185448).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Workstation Extension 12-SP5:

      zypper in -t patch SUSE-SLE-WE-12-SP5-2022-3911=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3911=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3911=1



Package List:

   - SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64):

      gstreamer-plugins-base-debuginfo-1.8.3-13.6.1
      gstreamer-plugins-base-debuginfo-32bit-1.8.3-13.6.1
      gstreamer-plugins-base-debugsource-1.8.3-13.6.1
      libgstfft-1_0-0-32bit-1.8.3-13.6.1
      libgstfft-1_0-0-debuginfo-32bit-1.8.3-13.6.1
      typelib-1_0-GstAudio-1_0-1.8.3-13.6.1
      typelib-1_0-GstPbutils-1_0-1.8.3-13.6.1
      typelib-1_0-GstTag-1_0-1.8.3-13.6.1
      typelib-1_0-GstVideo-1_0-1.8.3-13.6.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      gstreamer-plugins-base-debuginfo-1.8.3-13.6.1
      gstreamer-plugins-base-debugsource-1.8.3-13.6.1
      gstreamer-plugins-base-devel-1.8.3-13.6.1
      typelib-1_0-GstAllocators-1_0-1.8.3-13.6.1
      typelib-1_0-GstApp-1_0-1.8.3-13.6.1
      typelib-1_0-GstAudio-1_0-1.8.3-13.6.1
      typelib-1_0-GstFft-1_0-1.8.3-13.6.1
      typelib-1_0-GstPbutils-1_0-1.8.3-13.6.1
      typelib-1_0-GstRtp-1_0-1.8.3-13.6.1
      typelib-1_0-GstRtsp-1_0-1.8.3-13.6.1
      typelib-1_0-GstSdp-1_0-1.8.3-13.6.1
      typelib-1_0-GstTag-1_0-1.8.3-13.6.1
      typelib-1_0-GstVideo-1_0-1.8.3-13.6.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      gstreamer-plugins-base-1.8.3-13.6.1
      gstreamer-plugins-base-debuginfo-1.8.3-13.6.1
      gstreamer-plugins-base-debugsource-1.8.3-13.6.1
      libgstallocators-1_0-0-1.8.3-13.6.1
      libgstallocators-1_0-0-debuginfo-1.8.3-13.6.1
      libgstapp-1_0-0-1.8.3-13.6.1
      libgstapp-1_0-0-debuginfo-1.8.3-13.6.1
      libgstaudio-1_0-0-1.8.3-13.6.1
      libgstaudio-1_0-0-debuginfo-1.8.3-13.6.1
      libgstfft-1_0-0-1.8.3-13.6.1
      libgstfft-1_0-0-debuginfo-1.8.3-13.6.1
      libgstpbutils-1_0-0-1.8.3-13.6.1
      libgstpbutils-1_0-0-debuginfo-1.8.3-13.6.1
      libgstriff-1_0-0-1.8.3-13.6.1
      libgstriff-1_0-0-debuginfo-1.8.3-13.6.1
      libgstrtp-1_0-0-1.8.3-13.6.1
      libgstrtp-1_0-0-debuginfo-1.8.3-13.6.1
      libgstrtsp-1_0-0-1.8.3-13.6.1
      libgstrtsp-1_0-0-debuginfo-1.8.3-13.6.1
      libgstsdp-1_0-0-1.8.3-13.6.1
      libgstsdp-1_0-0-debuginfo-1.8.3-13.6.1
      libgsttag-1_0-0-1.8.3-13.6.1
      libgsttag-1_0-0-debuginfo-1.8.3-13.6.1
      libgstvideo-1_0-0-1.8.3-13.6.1
      libgstvideo-1_0-0-debuginfo-1.8.3-13.6.1

   - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64):

      gstreamer-plugins-base-debuginfo-32bit-1.8.3-13.6.1
      libgstapp-1_0-0-32bit-1.8.3-13.6.1
      libgstapp-1_0-0-debuginfo-32bit-1.8.3-13.6.1
      libgstaudio-1_0-0-32bit-1.8.3-13.6.1
      libgstaudio-1_0-0-debuginfo-32bit-1.8.3-13.6.1
      libgstpbutils-1_0-0-32bit-1.8.3-13.6.1
      libgstpbutils-1_0-0-debuginfo-32bit-1.8.3-13.6.1
      libgsttag-1_0-0-32bit-1.8.3-13.6.1
      libgsttag-1_0-0-debuginfo-32bit-1.8.3-13.6.1
      libgstvideo-1_0-0-32bit-1.8.3-13.6.1
      libgstvideo-1_0-0-debuginfo-32bit-1.8.3-13.6.1

   - SUSE Linux Enterprise Server 12-SP5 (noarch):

      gstreamer-plugins-base-lang-1.8.3-13.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-3522.html
   https://bugzilla.suse.com/1185448

SUSE: 2022:3911-1 moderate: gstreamer-plugins-base

November 8, 2022
An update that fixes one vulnerability is now available

Summary

This update for gstreamer-plugins-base fixes the following issues: - CVE-2021-3522: Fixed frame size check and potential invalid reads (bsc#1185448). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Workstation Extension 12-SP5: zypper in -t patch SUSE-SLE-WE-12-SP5-2022-3911=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3911=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3911=1 Package List: - SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64): gstreamer-plugins-base-debuginfo-1.8.3-13.6.1 gstreamer-plugins-base-debuginfo-32bit-1.8.3-13.6.1 gstreamer-plugins-base-debugsource-1.8.3-13.6.1 libgstfft-1_0-0-32bit-1.8.3-13.6.1 libgstfft-1_0-0-debuginfo-32bit-1.8.3-13.6.1 typelib-1_0-GstAudio-1_0-1.8.3-13.6.1 typelib-1_0-GstPbutils-1_0-1.8.3-13.6.1 typelib-1_0-GstTag-1_0-1.8.3-13.6.1 typelib-1_0-GstVideo-1_0-1.8.3-13.6.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): gstreamer-plugins-base-debuginfo-1.8.3-13.6.1 gstreamer-plugins-base-debugsource-1.8.3-13.6.1 gstreamer-plugins-base-devel-1.8.3-13.6.1 typelib-1_0-GstAllocators-1_0-1.8.3-13.6.1 typelib-1_0-GstApp-1_0-1.8.3-13.6.1 typelib-1_0-GstAudio-1_0-1.8.3-13.6.1 typelib-1_0-GstFft-1_0-1.8.3-13.6.1 typelib-1_0-GstPbutils-1_0-1.8.3-13.6.1 typelib-1_0-GstRtp-1_0-1.8.3-13.6.1 typelib-1_0-GstRtsp-1_0-1.8.3-13.6.1 typelib-1_0-GstSdp-1_0-1.8.3-13.6.1 typelib-1_0-GstTag-1_0-1.8.3-13.6.1 typelib-1_0-GstVideo-1_0-1.8.3-13.6.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): gstreamer-plugins-base-1.8.3-13.6.1 gstreamer-plugins-base-debuginfo-1.8.3-13.6.1 gstreamer-plugins-base-debugsource-1.8.3-13.6.1 libgstallocators-1_0-0-1.8.3-13.6.1 libgstallocators-1_0-0-debuginfo-1.8.3-13.6.1 libgstapp-1_0-0-1.8.3-13.6.1 libgstapp-1_0-0-debuginfo-1.8.3-13.6.1 libgstaudio-1_0-0-1.8.3-13.6.1 libgstaudio-1_0-0-debuginfo-1.8.3-13.6.1 libgstfft-1_0-0-1.8.3-13.6.1 libgstfft-1_0-0-debuginfo-1.8.3-13.6.1 libgstpbutils-1_0-0-1.8.3-13.6.1 libgstpbutils-1_0-0-debuginfo-1.8.3-13.6.1 libgstriff-1_0-0-1.8.3-13.6.1 libgstriff-1_0-0-debuginfo-1.8.3-13.6.1 libgstrtp-1_0-0-1.8.3-13.6.1 libgstrtp-1_0-0-debuginfo-1.8.3-13.6.1 libgstrtsp-1_0-0-1.8.3-13.6.1 libgstrtsp-1_0-0-debuginfo-1.8.3-13.6.1 libgstsdp-1_0-0-1.8.3-13.6.1 libgstsdp-1_0-0-debuginfo-1.8.3-13.6.1 libgsttag-1_0-0-1.8.3-13.6.1 libgsttag-1_0-0-debuginfo-1.8.3-13.6.1 libgstvideo-1_0-0-1.8.3-13.6.1 libgstvideo-1_0-0-debuginfo-1.8.3-13.6.1 - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64): gstreamer-plugins-base-debuginfo-32bit-1.8.3-13.6.1 libgstapp-1_0-0-32bit-1.8.3-13.6.1 libgstapp-1_0-0-debuginfo-32bit-1.8.3-13.6.1 libgstaudio-1_0-0-32bit-1.8.3-13.6.1 libgstaudio-1_0-0-debuginfo-32bit-1.8.3-13.6.1 libgstpbutils-1_0-0-32bit-1.8.3-13.6.1 libgstpbutils-1_0-0-debuginfo-32bit-1.8.3-13.6.1 libgsttag-1_0-0-32bit-1.8.3-13.6.1 libgsttag-1_0-0-debuginfo-32bit-1.8.3-13.6.1 libgstvideo-1_0-0-32bit-1.8.3-13.6.1 libgstvideo-1_0-0-debuginfo-32bit-1.8.3-13.6.1 - SUSE Linux Enterprise Server 12-SP5 (noarch): gstreamer-plugins-base-lang-1.8.3-13.6.1

References

#1185448

Cross- CVE-2021-3522

CVSS scores:

CVE-2021-3522 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2021-3522 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise Desktop 12-SP5

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE Linux Enterprise Workstation Extension 12-SP5

https://www.suse.com/security/cve/CVE-2021-3522.html

https://bugzilla.suse.com/1185448

Severity
Announcement ID: SUSE-SU-2022:3911-1
Rating: moderate

Related News