SUSE: 2022:4603-1 moderate: sqlite3 | LinuxSecurity.com

   SUSE Security Update: Security update for sqlite3
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4603-1
Rating:             moderate
References:         #1206337 
Cross-References:   CVE-2022-46908
CVSS scores:
                    CVE-2022-46908 (NVD) : 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
                    CVE-2022-46908 (SUSE): 5.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Affected Products:
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for sqlite3 fixes the following issues:

   - CVE-2022-46908: Properly implement the azProhibitedFunctions protection
     mechanism, when relying on --safe for execution of an untrusted CLI
     script (bsc#1206337).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4603=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4603=1



Package List:

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      sqlite3-debuginfo-3.39.3-9.26.1
      sqlite3-debugsource-3.39.3-9.26.1
      sqlite3-devel-3.39.3-9.26.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libsqlite3-0-3.39.3-9.26.1
      libsqlite3-0-debuginfo-3.39.3-9.26.1
      sqlite3-3.39.3-9.26.1
      sqlite3-debuginfo-3.39.3-9.26.1
      sqlite3-debugsource-3.39.3-9.26.1
      sqlite3-devel-3.39.3-9.26.1
      sqlite3-tcl-3.39.3-9.26.1

   - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64):

      libsqlite3-0-32bit-3.39.3-9.26.1
      libsqlite3-0-debuginfo-32bit-3.39.3-9.26.1


References:

   https://www.suse.com/security/cve/CVE-2022-46908.html
   https://bugzilla.suse.com/1206337

SUSE: 2022:4603-1 moderate: sqlite3

December 21, 2022
An update that fixes one vulnerability is now available

Summary

This update for sqlite3 fixes the following issues: - CVE-2022-46908: Properly implement the azProhibitedFunctions protection mechanism, when relying on --safe for execution of an untrusted CLI script (bsc#1206337). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4603=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4603=1 Package List: - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): sqlite3-debuginfo-3.39.3-9.26.1 sqlite3-debugsource-3.39.3-9.26.1 sqlite3-devel-3.39.3-9.26.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): libsqlite3-0-3.39.3-9.26.1 libsqlite3-0-debuginfo-3.39.3-9.26.1 sqlite3-3.39.3-9.26.1 sqlite3-debuginfo-3.39.3-9.26.1 sqlite3-debugsource-3.39.3-9.26.1 sqlite3-devel-3.39.3-9.26.1 sqlite3-tcl-3.39.3-9.26.1 - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64): libsqlite3-0-32bit-3.39.3-9.26.1 libsqlite3-0-debuginfo-32bit-3.39.3-9.26.1

References

#1206337

Cross- CVE-2022-46908

CVSS scores:

CVE-2022-46908 (NVD) : 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

CVE-2022-46908 (SUSE): 5.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Affected Products:

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

https://www.suse.com/security/cve/CVE-2022-46908.html

https://bugzilla.suse.com/1206337

Severity
Announcement ID: SUSE-SU-2022:4603-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.