SUSE: 2023:0002-1 moderate: sbd | LinuxSecurity.com

   SUSE Security Update: Security update for sbd
______________________________________________________________________________

Announcement ID:    SUSE-SU-2023:0002-1
Rating:             moderate
References:         #1180966 #1181400 #1185182 #1204319 
Affected Products:
                    SUSE Linux Enterprise High Availability 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that contains security fixes can now be installed.

Description:

   This update for sbd fixes the following issues:

   Update to version 1.5.1+20221128.8ec8e01:

   - sbd-inquisitor: fail startup if pacemaker integration is disabled while
     SBD_SYNC_RESOURCE_STARTUP is conflicting (bsc#1204319)
   - sbd-inquisitor: do not warn about startup syncing if pacemaker
     integration is even intentionally disabled (bsc#1204319)
   - sbd-inquisitor: log a warning if SBD_PACEMAKER is overridden by -P or
     -PP option (bsc#1204319)
   - sbd-inquisitor: ensure a log info only tells the fact about how
     SBD_PACEMAKER is set (bsc#1204319)
   - Added hardened to systemd service(s) (bsc#1181400).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2023-2=1

   - SUSE Linux Enterprise High Availability 15-SP4:

      zypper in -t patch SUSE-SLE-Product-HA-15-SP4-2023-2=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      sbd-1.5.1+20221128.8ec8e01-150400.3.3.1
      sbd-debuginfo-1.5.1+20221128.8ec8e01-150400.3.3.1
      sbd-debugsource-1.5.1+20221128.8ec8e01-150400.3.3.1
      sbd-devel-1.5.1+20221128.8ec8e01-150400.3.3.1
      sbd-devel-debuginfo-1.5.1+20221128.8ec8e01-150400.3.3.1

   - SUSE Linux Enterprise High Availability 15-SP4 (aarch64 ppc64le s390x x86_64):

      sbd-1.5.1+20221128.8ec8e01-150400.3.3.1
      sbd-debuginfo-1.5.1+20221128.8ec8e01-150400.3.3.1
      sbd-debugsource-1.5.1+20221128.8ec8e01-150400.3.3.1


References:

   https://bugzilla.suse.com/1180966
   https://bugzilla.suse.com/1181400
   https://bugzilla.suse.com/1185182
   https://bugzilla.suse.com/1204319

SUSE: 2023:0002-1 moderate: sbd

January 2, 2023
An update that contains security fixes can now be installed

Summary

This update for sbd fixes the following issues: Update to version 1.5.1+20221128.8ec8e01: - sbd-inquisitor: fail startup if pacemaker integration is disabled while SBD_SYNC_RESOURCE_STARTUP is conflicting (bsc#1204319) - sbd-inquisitor: do not warn about startup syncing if pacemaker integration is even intentionally disabled (bsc#1204319) - sbd-inquisitor: log a warning if SBD_PACEMAKER is overridden by -P or -PP option (bsc#1204319) - sbd-inquisitor: ensure a log info only tells the fact about how SBD_PACEMAKER is set (bsc#1204319) - Added hardened to systemd service(s) (bsc#1181400). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2023-2=1 - SUSE Linux Enterprise High Availability 15-SP4: zypper in -t patch SUSE-SLE-Product-HA-15-SP4-2023-2=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): sbd-1.5.1+20221128.8ec8e01-150400.3.3.1 sbd-debuginfo-1.5.1+20221128.8ec8e01-150400.3.3.1 sbd-debugsource-1.5.1+20221128.8ec8e01-150400.3.3.1 sbd-devel-1.5.1+20221128.8ec8e01-150400.3.3.1 sbd-devel-debuginfo-1.5.1+20221128.8ec8e01-150400.3.3.1 - SUSE Linux Enterprise High Availability 15-SP4 (aarch64 ppc64le s390x x86_64): sbd-1.5.1+20221128.8ec8e01-150400.3.3.1 sbd-debuginfo-1.5.1+20221128.8ec8e01-150400.3.3.1 sbd-debugsource-1.5.1+20221128.8ec8e01-150400.3.3.1

References

#1180966 #1181400 #1185182 #1204319

Affected Products:

SUSE Linux Enterprise High Availability 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://bugzilla.suse.com/1180966

https://bugzilla.suse.com/1181400

https://bugzilla.suse.com/1185182

https://bugzilla.suse.com/1204319

Severity
Announcement ID: SUSE-SU-2023:0002-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.