SUSE Container Update Advisory: suse/sle15
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2023:1374-1
Container Tags        : suse/sle15:15.2 , suse/sle15:15.2.9.5.289
Container Release     : 9.5.289
Severity              : moderate
Type                  : security
References            : 1209533 1209713 1209714 1210135 1210507 CVE-2022-4899 CVE-2023-24593
                        CVE-2023-25180 CVE-2023-29383 
-----------------------------------------------------------------

The container suse/sle15 was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:2068-1
Released:    Fri Apr 28 13:55:00 2023
Summary:     Security update for shadow
Type:        security
Severity:    moderate
References:  1210507,CVE-2023-29383
This update for shadow fixes the following issues:

- CVE-2023-29383: Fixed apparent /etc/shadow manipulation via chfn (bsc#1210507).

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:2074-1
Released:    Fri Apr 28 17:02:25 2023
Summary:     Security update for zstd
Type:        security
Severity:    moderate
References:  1209533,CVE-2022-4899
This update for zstd fixes the following issues:

- CVE-2022-4899: Fixed buffer overrun in util.c (bsc#1209533).

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:2076-1
Released:    Fri Apr 28 17:35:05 2023
Summary:     Security update for glib2
Type:        security
Severity:    moderate
References:  1209713,1209714,1210135,CVE-2023-24593,CVE-2023-25180
This update for glib2 fixes the following issues:

- CVE-2023-24593: Fixed a denial of service caused by handling a malicious text-form variant (bsc#1209714).
- CVE-2023-25180: Fixed a denial of service caused by malicious serialised variant (bsc#1209713).

The following non-security bug was fixed:

- Fixed regression on s390x (bsc#1210135, glgo#GNOME/glib!2978).


The following package changes have been done:

- libglib-2_0-0-2.62.6-150200.3.15.1 updated
- libzstd1-1.4.4-150000.1.9.1 updated
- shadow-4.6-150100.3.8.1 updated

SUSE: 2023:1374-1 suse/sle15 Security Update

April 30, 2023
The container suse/sle15 was updated

Summary

Advisory ID: SUSE-SU-2023:2068-1 Released: Fri Apr 28 13:55:00 2023 Summary: Security update for shadow Type: security Severity: moderate Advisory ID: SUSE-SU-2023:2074-1 Released: Fri Apr 28 17:02:25 2023 Summary: Security update for zstd Type: security Severity: moderate Advisory ID: SUSE-SU-2023:2076-1 Released: Fri Apr 28 17:35:05 2023 Summary: Security update for glib2 Type: security Severity: moderate

References

References : 1209533 1209713 1209714 1210135 1210507 CVE-2022-4899 CVE-2023-24593

CVE-2023-25180 CVE-2023-29383

1210507,CVE-2023-29383

This update for shadow fixes the following issues:

- CVE-2023-29383: Fixed apparent /etc/shadow manipulation via chfn (bsc#1210507).

1209533,CVE-2022-4899

This update for zstd fixes the following issues:

- CVE-2022-4899: Fixed buffer overrun in util.c (bsc#1209533).

1209713,1209714,1210135,CVE-2023-24593,CVE-2023-25180

This update for glib2 fixes the following issues:

- CVE-2023-24593: Fixed a denial of service caused by handling a malicious text-form variant (bsc#1209714).

- CVE-2023-25180: Fixed a denial of service caused by malicious serialised variant (bsc#1209713).

The following non-security bug was fixed:

- Fixed regression on s390x (bsc#1210135, glgo#GNOME/glib!2978).

The following package changes have been done:

- libglib-2_0-0-2.62.6-150200.3.15.1 updated

- libzstd1-1.4.4-150000.1.9.1 updated

- shadow-4.6-150100.3.8.1 updated

Severity
Container Advisory ID : SUSE-CU-2023:1374-1
Container Tags : suse/sle15:15.2 , suse/sle15:15.2.9.5.289
Container Release : 9.5.289
Severity : moderate
Type : security

Related News