SUSE Container Update Advisory: bci/rust
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2023:2137-1
Container Tags        : bci/rust:1.69 , bci/rust:1.69-2.5.2 , bci/rust:oldstable , bci/rust:oldstable-2.5.2
Container Release     : 5.2
Severity              : important
Type                  : security
References            : 1201627 1207534 1211430 CVE-2022-4304 CVE-2023-2650 
-----------------------------------------------------------------

The container bci/rust was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: 29171
Released:    Tue Jun 20 12:29:00 2023
Summary:     Security update for openssl-1_1
Type:        security
Severity:    important
References:  1201627,1207534,1211430,CVE-2022-4304,CVE-2023-2650
This update for openssl-1_1 fixes the following issues:

- CVE-2023-2650: Fixed possible denial of service translating ASN.1 object identifiers (bsc#1211430).
- CVE-2022-4304: Reworked the fix for the Timing-Oracle in RSA decryption.
  The previous fix for this timing side channel turned out to cause a
  severe 2-3x performance regression in the typical use case (bsc#1207534).

- Update further expiring certificates that affect tests (bsc#1201627)

-----------------------------------------------------------------
Advisory ID: SUSE-RU-2023:2625-1
Released:    Fri Jun 23 17:16:11 2023
Summary:     Recommended update for gcc12
Type:        recommended
Severity:    moderate
References:  
This update for gcc12 fixes the following issues:

- Update to GCC 12.3 release, 0c61aa720e62f1baf0bfd178e283, git1204

  * includes regression and other bug fixes

- Speed up builds with --enable-link-serialization.

- Update embedded newlib to version 4.2.0


The following package changes have been done:

- libgcc_s1-12.3.0+git1204-150000.1.10.1 updated
- libstdc++6-12.3.0+git1204-150000.1.10.1 updated
- libopenssl1_1-1.1.1l-150500.17.6.1 updated
- libopenssl1_1-hmac-1.1.1l-150500.17.6.1 updated
- libatomic1-12.3.0+git1204-150000.1.10.1 updated
- libgomp1-12.3.0+git1204-150000.1.10.1 updated
- libitm1-12.3.0+git1204-150000.1.10.1 updated
- liblsan0-12.3.0+git1204-150000.1.10.1 updated
- libubsan1-12.3.0+git1204-150000.1.10.1 updated
- container:sles15-image-15.0.0-36.5.7 updated

SUSE: 2023:2137-1 bci/rust Security Update

June 26, 2023
The container bci/rust was updated

Summary

Advisory ID: 29171 Released: Tue Jun 20 12:29:00 2023 Summary: Security update for openssl-1_1 Type: security Severity: important Advisory ID: SUSE-RU-2023:2625-1 Released: Fri Jun 23 17:16:11 2023 Summary: Recommended update for gcc12 Type: recommended Severity: moderate

References

References : 1201627 1207534 1211430 CVE-2022-4304 CVE-2023-2650

1201627,1207534,1211430,CVE-2022-4304,CVE-2023-2650

This update for openssl-1_1 fixes the following issues:

- CVE-2023-2650: Fixed possible denial of service translating ASN.1 object identifiers (bsc#1211430).

- CVE-2022-4304: Reworked the fix for the Timing-Oracle in RSA decryption.

The previous fix for this timing side channel turned out to cause a

severe 2-3x performance regression in the typical use case (bsc#1207534).

- Update further expiring certificates that affect tests (bsc#1201627)

This update for gcc12 fixes the following issues:

- Update to GCC 12.3 release, 0c61aa720e62f1baf0bfd178e283, git1204

* includes regression and other bug fixes

- Speed up builds with --enable-link-serialization.

- Update embedded newlib to version 4.2.0

The following package changes have been done:

- libgcc_s1-12.3.0+git1204-150000.1.10.1 updated

- libstdc++6-12.3.0+git1204-150000.1.10.1 updated

- libopenssl1_1-1.1.1l-150500.17.6.1 updated

- libopenssl1_1-hmac-1.1.1l-150500.17.6.1 updated

- libatomic1-12.3.0+git1204-150000.1.10.1 updated

- libgomp1-12.3.0+git1204-150000.1.10.1 updated

- libitm1-12.3.0+git1204-150000.1.10.1 updated

- liblsan0-12.3.0+git1204-150000.1.10.1 updated

- libubsan1-12.3.0+git1204-150000.1.10.1 updated

- container:sles15-image-15.0.0-36.5.7 updated

Severity
Container Advisory ID : SUSE-CU-2023:2137-1
Container Tags : bci/rust:1.69 , bci/rust:1.69-2.5.2 , bci/rust:oldstable , bci/rust:oldstable-2.5.2
Container Release : 5.2
Severity : important
Type : security
Feedback