# Security update for php-composer2

Announcement ID: SUSE-SU-2023:4041-1  
Rating: moderate  
References:

  * #1215859

  
Cross-References:

  * CVE-2023-43655

  
CVSS scores:

  * CVE-2023-43655 ( SUSE ):  6.4 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-43655 ( NVD ):  6.4 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

  
Affected Products:

  * openSUSE Leap 15.4
  * openSUSE Leap 15.5
  * SUSE Linux Enterprise High Performance Computing 15 SP4
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Server 15 SP4
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5
  * SUSE Manager Proxy 4.3
  * SUSE Manager Retail Branch Server 4.3
  * SUSE Manager Server 4.3
  * Web and Scripting Module 15-SP4
  * Web and Scripting Module 15-SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for php-composer2 fixes the following issues:

  * CVE-2023-43655: Fixed a remote code execution issue that could be triggered
    if users published a web-accessible composer.phar file (bsc#1215859).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2023-4041=1 openSUSE-SLE-15.4-2023-4041=1

  * openSUSE Leap 15.5  
    zypper in -t patch openSUSE-SLE-15.5-2023-4041=1

  * Web and Scripting Module 15-SP4  
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP4-2023-4041=1

  * Web and Scripting Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP5-2023-4041=1

## Package List:

  * openSUSE Leap 15.4 (noarch)
    * php-composer2-2.2.3-150400.3.6.1
  * openSUSE Leap 15.5 (noarch)
    * php-composer2-2.2.3-150400.3.6.1
  * Web and Scripting Module 15-SP4 (noarch)
    * php-composer2-2.2.3-150400.3.6.1
  * Web and Scripting Module 15-SP5 (noarch)
    * php-composer2-2.2.3-150400.3.6.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-43655.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1215859

SUSE: 2023:4041-1 moderate: php-composer2

October 10, 2023
* #1215859 Cross-References: * CVE-2023-43655

Summary

## This update for php-composer2 fixes the following issues: * CVE-2023-43655: Fixed a remote code execution issue that could be triggered if users published a web-accessible composer.phar file (bsc#1215859). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2023-4041=1 openSUSE-SLE-15.4-2023-4041=1 * openSUSE Leap 15.5 zypper in -t patch openSUSE-SLE-15.5-2023-4041=1 * Web and Scripting Module 15-SP4 zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP4-2023-4041=1 * Web and Scripting Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP5-2023-4041=1 ## Package List: * openSUSE Leap 15.4 (noarch) * php-composer2-2.2.3-150400.3.6.1 * openSUSE Leap 15.5 (noarch) * php-composer2-2.2.3-150400.3.6.1 * Web and Scripting Module 15-SP4 (noarch) * php-composer2-2.2.3-150400.3.6.1 * Web and Scripting Module 15-SP5 (noarch) * php-composer2-2.2.3-150400.3.6.1

References

* #1215859

Cross-

* CVE-2023-43655

CVSS scores:

* CVE-2023-43655 ( SUSE ): 6.4 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-43655 ( NVD ): 6.4 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.4

* openSUSE Leap 15.5

* SUSE Linux Enterprise High Performance Computing 15 SP4

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Server 15 SP4

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP4

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

* SUSE Manager Proxy 4.3

* SUSE Manager Retail Branch Server 4.3

* SUSE Manager Server 4.3

* Web and Scripting Module 15-SP4

* Web and Scripting Module 15-SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-43655.html

* https://bugzilla.suse.com/show_bug.cgi?id=1215859

Severity
Announcement ID: SUSE-SU-2023:4041-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo