# Security update for gstreamer-plugins-bad

Announcement ID: SUSE-SU-2023:4595-1  
Rating: important  
References:

  * bsc#1215793
  * bsc#1215796

  
Cross-References:

  * CVE-2023-40474
  * CVE-2023-40476

  
CVSS scores:

  * CVE-2023-40474 ( SUSE ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-40476 ( SUSE ):  8.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 15 SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise Server 15 SP2
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2

  
  
An update that solves two vulnerabilities can now be installed.

## Description:

This update for gstreamer-plugins-bad fixes the following issues:

  * CVE-2023-40474: Fixed integer overflow causing out of bounds writes when
    handling invalid uncompressed video (bsc#1215796).
  * CVE-2023-40476: Fixed possible overflow using max_sub_layers_minus1
    (bsc#1215793).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise Server for SAP Applications 15 SP2  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4595=1

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4595=1

  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4595=1

## Package List:

  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64)
    * typelib-1_0-GstPlayer-1_0-1.16.3-150200.4.13.2
    * libgstwebrtc-1_0-0-1.16.3-150200.4.13.2
    * libgstbasecamerabinsrc-1_0-0-1.16.3-150200.4.13.2
    * libgstbasecamerabinsrc-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-devel-1.16.3-150200.4.13.2
    * libgstplayer-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * typelib-1_0-GstInsertBin-1_0-1.16.3-150200.4.13.2
    * libgstmpegts-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstphotography-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-1.16.3-150200.4.13.2
    * libgstbadaudio-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstcodecparsers-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-chromaprint-debuginfo-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-debuginfo-1.16.3-150200.4.13.2
    * libgstphotography-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstmpegts-1_0-0-1.16.3-150200.4.13.2
    * libgsturidownloader-1_0-0-1.16.3-150200.4.13.2
    * typelib-1_0-GstWebRTC-1_0-1.16.3-150200.4.13.2
    * libgstinsertbin-1_0-0-1.16.3-150200.4.13.2
    * libgstwayland-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstbadaudio-1_0-0-1.16.3-150200.4.13.2
    * libgstwebrtc-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * typelib-1_0-GstMpegts-1_0-1.16.3-150200.4.13.2
    * libgstsctp-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstplayer-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-chromaprint-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-debugsource-1.16.3-150200.4.13.2
    * libgstcodecparsers-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstsctp-1_0-0-1.16.3-150200.4.13.2
    * libgstadaptivedemux-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstisoff-1_0-0-1.16.3-150200.4.13.2
    * libgstwayland-1_0-0-1.16.3-150200.4.13.2
    * libgstinsertbin-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstisoff-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstadaptivedemux-1_0-0-1.16.3-150200.4.13.2
    * libgsturidownloader-1_0-0-debuginfo-1.16.3-150200.4.13.2
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch)
    * gstreamer-plugins-bad-lang-1.16.3-150200.4.13.2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64
    x86_64)
    * typelib-1_0-GstPlayer-1_0-1.16.3-150200.4.13.2
    * libgstwebrtc-1_0-0-1.16.3-150200.4.13.2
    * libgstbasecamerabinsrc-1_0-0-1.16.3-150200.4.13.2
    * libgstbasecamerabinsrc-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-devel-1.16.3-150200.4.13.2
    * libgstplayer-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * typelib-1_0-GstInsertBin-1_0-1.16.3-150200.4.13.2
    * libgstmpegts-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstphotography-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-1.16.3-150200.4.13.2
    * libgstbadaudio-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstcodecparsers-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-chromaprint-debuginfo-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-debuginfo-1.16.3-150200.4.13.2
    * libgstphotography-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstmpegts-1_0-0-1.16.3-150200.4.13.2
    * libgsturidownloader-1_0-0-1.16.3-150200.4.13.2
    * typelib-1_0-GstWebRTC-1_0-1.16.3-150200.4.13.2
    * libgstinsertbin-1_0-0-1.16.3-150200.4.13.2
    * libgstwayland-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstbadaudio-1_0-0-1.16.3-150200.4.13.2
    * libgstwebrtc-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * typelib-1_0-GstMpegts-1_0-1.16.3-150200.4.13.2
    * libgstsctp-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstplayer-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-chromaprint-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-debugsource-1.16.3-150200.4.13.2
    * libgstcodecparsers-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstsctp-1_0-0-1.16.3-150200.4.13.2
    * libgstadaptivedemux-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstisoff-1_0-0-1.16.3-150200.4.13.2
    * libgstwayland-1_0-0-1.16.3-150200.4.13.2
    * libgstinsertbin-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstisoff-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstadaptivedemux-1_0-0-1.16.3-150200.4.13.2
    * libgsturidownloader-1_0-0-debuginfo-1.16.3-150200.4.13.2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch)
    * gstreamer-plugins-bad-lang-1.16.3-150200.4.13.2
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x
    x86_64)
    * typelib-1_0-GstPlayer-1_0-1.16.3-150200.4.13.2
    * libgstwebrtc-1_0-0-1.16.3-150200.4.13.2
    * libgstbasecamerabinsrc-1_0-0-1.16.3-150200.4.13.2
    * libgstbasecamerabinsrc-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-devel-1.16.3-150200.4.13.2
    * libgstplayer-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * typelib-1_0-GstInsertBin-1_0-1.16.3-150200.4.13.2
    * libgstmpegts-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstphotography-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-1.16.3-150200.4.13.2
    * libgstbadaudio-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstcodecparsers-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-chromaprint-debuginfo-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-debuginfo-1.16.3-150200.4.13.2
    * libgstphotography-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstmpegts-1_0-0-1.16.3-150200.4.13.2
    * libgsturidownloader-1_0-0-1.16.3-150200.4.13.2
    * typelib-1_0-GstWebRTC-1_0-1.16.3-150200.4.13.2
    * libgstinsertbin-1_0-0-1.16.3-150200.4.13.2
    * libgstwayland-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstbadaudio-1_0-0-1.16.3-150200.4.13.2
    * libgstwebrtc-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * typelib-1_0-GstMpegts-1_0-1.16.3-150200.4.13.2
    * libgstsctp-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstplayer-1_0-0-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-chromaprint-1.16.3-150200.4.13.2
    * gstreamer-plugins-bad-debugsource-1.16.3-150200.4.13.2
    * libgstcodecparsers-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstsctp-1_0-0-1.16.3-150200.4.13.2
    * libgstadaptivedemux-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstisoff-1_0-0-1.16.3-150200.4.13.2
    * libgstwayland-1_0-0-1.16.3-150200.4.13.2
    * libgstinsertbin-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstisoff-1_0-0-debuginfo-1.16.3-150200.4.13.2
    * libgstadaptivedemux-1_0-0-1.16.3-150200.4.13.2
    * libgsturidownloader-1_0-0-debuginfo-1.16.3-150200.4.13.2
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch)
    * gstreamer-plugins-bad-lang-1.16.3-150200.4.13.2

## References:

  * https://www.suse.com/security/cve/CVE-2023-40474.html
  * https://www.suse.com/security/cve/CVE-2023-40476.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1215793
  * https://bugzilla.suse.com/show_bug.cgi?id=1215796

SUSE: 2023:4595-1 important: gstreamer-plugins-bad

November 28, 2023
* bsc#1215793 * bsc#1215796 Cross-References: * CVE-2023-40474

Summary

## This update for gstreamer-plugins-bad fixes the following issues: * CVE-2023-40474: Fixed integer overflow causing out of bounds writes when handling invalid uncompressed video (bsc#1215796). * CVE-2023-40476: Fixed possible overflow using max_sub_layers_minus1 (bsc#1215793). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise Server for SAP Applications 15 SP2 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4595=1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4595=1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4595=1 ## Package List: * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64) * typelib-1_0-GstPlayer-1_0-1.16.3-150200.4.13.2 * libgstwebrtc-1_0-0-1.16.3-150200.4.13.2 * libgstbasecamerabinsrc-1_0-0-1.16.3-150200.4.13.2 * libgstbasecamerabinsrc-1_0-0-debuginfo-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-devel-1.16.3-150200.4.13.2 * libgstplayer-1_0-0-debuginfo-1.16.3-150200.4.13.2 * typelib-1_0-GstInsertBin-1_0-1.16.3-150200.4.13.2 * libgstmpegts-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstphotography-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-1.16.3-150200.4.13.2 * libgstbadaudio-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstcodecparsers-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-chromaprint-debuginfo-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-debuginfo-1.16.3-150200.4.13.2 * libgstphotography-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstmpegts-1_0-0-1.16.3-150200.4.13.2 * libgsturidownloader-1_0-0-1.16.3-150200.4.13.2 * typelib-1_0-GstWebRTC-1_0-1.16.3-150200.4.13.2 * libgstinsertbin-1_0-0-1.16.3-150200.4.13.2 * libgstwayland-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstbadaudio-1_0-0-1.16.3-150200.4.13.2 * libgstwebrtc-1_0-0-debuginfo-1.16.3-150200.4.13.2 * typelib-1_0-GstMpegts-1_0-1.16.3-150200.4.13.2 * libgstsctp-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstplayer-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-chromaprint-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-debugsource-1.16.3-150200.4.13.2 * libgstcodecparsers-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstsctp-1_0-0-1.16.3-150200.4.13.2 * libgstadaptivedemux-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstisoff-1_0-0-1.16.3-150200.4.13.2 * libgstwayland-1_0-0-1.16.3-150200.4.13.2 * libgstinsertbin-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstisoff-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstadaptivedemux-1_0-0-1.16.3-150200.4.13.2 * libgsturidownloader-1_0-0-debuginfo-1.16.3-150200.4.13.2 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch) * gstreamer-plugins-bad-lang-1.16.3-150200.4.13.2 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64 x86_64) * typelib-1_0-GstPlayer-1_0-1.16.3-150200.4.13.2 * libgstwebrtc-1_0-0-1.16.3-150200.4.13.2 * libgstbasecamerabinsrc-1_0-0-1.16.3-150200.4.13.2 * libgstbasecamerabinsrc-1_0-0-debuginfo-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-devel-1.16.3-150200.4.13.2 * libgstplayer-1_0-0-debuginfo-1.16.3-150200.4.13.2 * typelib-1_0-GstInsertBin-1_0-1.16.3-150200.4.13.2 * libgstmpegts-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstphotography-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-1.16.3-150200.4.13.2 * libgstbadaudio-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstcodecparsers-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-chromaprint-debuginfo-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-debuginfo-1.16.3-150200.4.13.2 * libgstphotography-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstmpegts-1_0-0-1.16.3-150200.4.13.2 * libgsturidownloader-1_0-0-1.16.3-150200.4.13.2 * typelib-1_0-GstWebRTC-1_0-1.16.3-150200.4.13.2 * libgstinsertbin-1_0-0-1.16.3-150200.4.13.2 * libgstwayland-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstbadaudio-1_0-0-1.16.3-150200.4.13.2 * libgstwebrtc-1_0-0-debuginfo-1.16.3-150200.4.13.2 * typelib-1_0-GstMpegts-1_0-1.16.3-150200.4.13.2 * libgstsctp-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstplayer-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-chromaprint-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-debugsource-1.16.3-150200.4.13.2 * libgstcodecparsers-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstsctp-1_0-0-1.16.3-150200.4.13.2 * libgstadaptivedemux-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstisoff-1_0-0-1.16.3-150200.4.13.2 * libgstwayland-1_0-0-1.16.3-150200.4.13.2 * libgstinsertbin-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstisoff-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstadaptivedemux-1_0-0-1.16.3-150200.4.13.2 * libgsturidownloader-1_0-0-debuginfo-1.16.3-150200.4.13.2 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch) * gstreamer-plugins-bad-lang-1.16.3-150200.4.13.2 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x x86_64) * typelib-1_0-GstPlayer-1_0-1.16.3-150200.4.13.2 * libgstwebrtc-1_0-0-1.16.3-150200.4.13.2 * libgstbasecamerabinsrc-1_0-0-1.16.3-150200.4.13.2 * libgstbasecamerabinsrc-1_0-0-debuginfo-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-devel-1.16.3-150200.4.13.2 * libgstplayer-1_0-0-debuginfo-1.16.3-150200.4.13.2 * typelib-1_0-GstInsertBin-1_0-1.16.3-150200.4.13.2 * libgstmpegts-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstphotography-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-1.16.3-150200.4.13.2 * libgstbadaudio-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstcodecparsers-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-chromaprint-debuginfo-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-debuginfo-1.16.3-150200.4.13.2 * libgstphotography-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstmpegts-1_0-0-1.16.3-150200.4.13.2 * libgsturidownloader-1_0-0-1.16.3-150200.4.13.2 * typelib-1_0-GstWebRTC-1_0-1.16.3-150200.4.13.2 * libgstinsertbin-1_0-0-1.16.3-150200.4.13.2 * libgstwayland-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstbadaudio-1_0-0-1.16.3-150200.4.13.2 * libgstwebrtc-1_0-0-debuginfo-1.16.3-150200.4.13.2 * typelib-1_0-GstMpegts-1_0-1.16.3-150200.4.13.2 * libgstsctp-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstplayer-1_0-0-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-chromaprint-1.16.3-150200.4.13.2 * gstreamer-plugins-bad-debugsource-1.16.3-150200.4.13.2 * libgstcodecparsers-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstsctp-1_0-0-1.16.3-150200.4.13.2 * libgstadaptivedemux-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstisoff-1_0-0-1.16.3-150200.4.13.2 * libgstwayland-1_0-0-1.16.3-150200.4.13.2 * libgstinsertbin-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstisoff-1_0-0-debuginfo-1.16.3-150200.4.13.2 * libgstadaptivedemux-1_0-0-1.16.3-150200.4.13.2 * libgsturidownloader-1_0-0-debuginfo-1.16.3-150200.4.13.2 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch) * gstreamer-plugins-bad-lang-1.16.3-150200.4.13.2

References

* bsc#1215793

* bsc#1215796

Cross-

* CVE-2023-40474

* CVE-2023-40476

CVSS scores:

* CVE-2023-40474 ( SUSE ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-40476 ( SUSE ): 8.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Affected Products:

* SUSE Linux Enterprise High Performance Computing 15 SP2

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise Server 15 SP2

* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise Server for SAP Applications 15 SP2

An update that solves two vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-40474.html

* https://www.suse.com/security/cve/CVE-2023-40476.html

* https://bugzilla.suse.com/show_bug.cgi?id=1215793

* https://bugzilla.suse.com/show_bug.cgi?id=1215796

Severity
Announcement ID: SUSE-SU-2023:4595-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo