# Security update for xwayland

Announcement ID: SUSE-SU-2023:4926-1  
Rating: important  
References:

  * bsc#1217765

  
Cross-References:

  * CVE-2023-6377

  
CVSS scores:

  * CVE-2023-6377 ( SUSE ):  8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

  
Affected Products:

  * openSUSE Leap 15.4
  * SUSE Linux Enterprise Desktop 15 SP4
  * SUSE Linux Enterprise Server 15 SP4
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4
  * SUSE Linux Enterprise Workstation Extension 15 SP4

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for xwayland fixes the following issues:

  * CVE-2023-6377: Fixed out-of-bounds memory write in XKB button actions
    (bsc#1217765).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2023-4926=1 openSUSE-SLE-15.4-2023-4926=1

  * SUSE Linux Enterprise Workstation Extension 15 SP4  
    zypper in -t patch SUSE-SLE-Product-WE-15-SP4-2023-4926=1

## Package List:

  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
    * xwayland-debugsource-21.1.4-150400.3.26.1
    * xwayland-devel-21.1.4-150400.3.26.1
    * xwayland-debuginfo-21.1.4-150400.3.26.1
    * xwayland-21.1.4-150400.3.26.1
  * SUSE Linux Enterprise Workstation Extension 15 SP4 (x86_64)
    * xwayland-debugsource-21.1.4-150400.3.26.1
    * xwayland-debuginfo-21.1.4-150400.3.26.1
    * xwayland-21.1.4-150400.3.26.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-6377.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1217765

SUSE: 2023:4926-1 important: xwayland

December 20, 2023
* bsc#1217765 Cross-References: * CVE-2023-6377

Summary

## This update for xwayland fixes the following issues: * CVE-2023-6377: Fixed out-of-bounds memory write in XKB button actions (bsc#1217765). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2023-4926=1 openSUSE-SLE-15.4-2023-4926=1 * SUSE Linux Enterprise Workstation Extension 15 SP4 zypper in -t patch SUSE-SLE-Product-WE-15-SP4-2023-4926=1 ## Package List: * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586) * xwayland-debugsource-21.1.4-150400.3.26.1 * xwayland-devel-21.1.4-150400.3.26.1 * xwayland-debuginfo-21.1.4-150400.3.26.1 * xwayland-21.1.4-150400.3.26.1 * SUSE Linux Enterprise Workstation Extension 15 SP4 (x86_64) * xwayland-debugsource-21.1.4-150400.3.26.1 * xwayland-debuginfo-21.1.4-150400.3.26.1 * xwayland-21.1.4-150400.3.26.1

References

* bsc#1217765

Cross-

* CVE-2023-6377

CVSS scores:

* CVE-2023-6377 ( SUSE ): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.4

* SUSE Linux Enterprise Desktop 15 SP4

* SUSE Linux Enterprise Server 15 SP4

* SUSE Linux Enterprise Server for SAP Applications 15 SP4

* SUSE Linux Enterprise Workstation Extension 15 SP4

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-6377.html

* https://bugzilla.suse.com/show_bug.cgi?id=1217765

Severity
Announcement ID: SUSE-SU-2023:4926-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo