# Security update for libcryptopp

Announcement ID: SUSE-SU-2023:4957-1  
Rating: moderate  
References:

  * bsc#1218219

  
Cross-References:

  * CVE-2023-50980

  
CVSS scores:

  * CVE-2023-50980 ( SUSE ):  5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

  
Affected Products:

  * openSUSE Leap 15.4

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for libcryptopp fixes the following issues:

  * CVE-2023-50980: Fixed DoS via malformed DER public key file (bsc#1218219).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch openSUSE-SLE-15.4-2023-4957=1

## Package List:

  * openSUSE Leap 15.4 (x86_64)
    * libcryptopp5_6_5-32bit-debuginfo-5.6.5-150000.1.9.1
    * libcryptopp5_6_5-32bit-5.6.5-150000.1.9.1
  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
    * libcryptopp5_6_5-debuginfo-5.6.5-150000.1.9.1
    * libcryptopp5_6_5-5.6.5-150000.1.9.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-50980.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1218219

SUSE: 2023:4957-1 moderate: libcryptopp

December 21, 2023
* bsc#1218219 Cross-References: * CVE-2023-50980

Summary

## This update for libcryptopp fixes the following issues: * CVE-2023-50980: Fixed DoS via malformed DER public key file (bsc#1218219). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch openSUSE-SLE-15.4-2023-4957=1 ## Package List: * openSUSE Leap 15.4 (x86_64) * libcryptopp5_6_5-32bit-debuginfo-5.6.5-150000.1.9.1 * libcryptopp5_6_5-32bit-5.6.5-150000.1.9.1 * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64) * libcryptopp5_6_5-debuginfo-5.6.5-150000.1.9.1 * libcryptopp5_6_5-5.6.5-150000.1.9.1

References

* bsc#1218219

Cross-

* CVE-2023-50980

CVSS scores:

* CVE-2023-50980 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Affected Products:

* openSUSE Leap 15.4

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-50980.html

* https://bugzilla.suse.com/show_bug.cgi?id=1218219

Severity
Announcement ID: SUSE-SU-2023:4957-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo