# Security update for tomcat10

Announcement ID: SUSE-SU-2024:0208-1  
Rating: moderate  
References:

  * bsc#1217649

  
Cross-References:

  * CVE-2023-46589

  
CVSS scores:

  * CVE-2023-46589 ( SUSE ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
  * CVE-2023-46589 ( NVD ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

  
Affected Products:

  * openSUSE Leap 15.5
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5
  * Web and Scripting Module 15-SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for tomcat10 fixes the following issues:

Updated to Tomcat 10.1.18

  * CVE-2023-46589: Fixed HTTP request smuggling due to incorrect headers
    parsing (bsc#1217649)

Find the full release notes at:

https://tomcat.apache.org/tomcat-9.0-doc/changelog.html

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.5  
    zypper in -t patch openSUSE-SLE-15.5-2024-208=1

  * Web and Scripting Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP5-2024-208=1

## Package List:

  * openSUSE Leap 15.5 (noarch)
    * tomcat10-el-5_0-api-10.1.18-150200.5.8.1
    * tomcat10-jsp-3_1-api-10.1.18-150200.5.8.1
    * tomcat10-servlet-6_0-api-10.1.18-150200.5.8.1
    * tomcat10-embed-10.1.18-150200.5.8.1
    * tomcat10-admin-webapps-10.1.18-150200.5.8.1
    * tomcat10-docs-webapp-10.1.18-150200.5.8.1
    * tomcat10-10.1.18-150200.5.8.1
    * tomcat10-jsvc-10.1.18-150200.5.8.1
    * tomcat10-lib-10.1.18-150200.5.8.1
    * tomcat10-webapps-10.1.18-150200.5.8.1
  * Web and Scripting Module 15-SP5 (noarch)
    * tomcat10-el-5_0-api-10.1.18-150200.5.8.1
    * tomcat10-jsp-3_1-api-10.1.18-150200.5.8.1
    * tomcat10-servlet-6_0-api-10.1.18-150200.5.8.1
    * tomcat10-admin-webapps-10.1.18-150200.5.8.1
    * tomcat10-10.1.18-150200.5.8.1
    * tomcat10-lib-10.1.18-150200.5.8.1
    * tomcat10-webapps-10.1.18-150200.5.8.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-46589.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1217649

SUSE: 2024:0208-1 moderate: tomcat10

January 24, 2024
* bsc#1217649 Cross-References: * CVE-2023-46589

Summary

## This update for tomcat10 fixes the following issues: Updated to Tomcat 10.1.18 * CVE-2023-46589: Fixed HTTP request smuggling due to incorrect headers parsing (bsc#1217649) Find the full release notes at: https://tomcat.apache.org/tomcat-9.0-doc/changelog.html ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.5 zypper in -t patch openSUSE-SLE-15.5-2024-208=1 * Web and Scripting Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP5-2024-208=1 ## Package List: * openSUSE Leap 15.5 (noarch) * tomcat10-el-5_0-api-10.1.18-150200.5.8.1 * tomcat10-jsp-3_1-api-10.1.18-150200.5.8.1 * tomcat10-servlet-6_0-api-10.1.18-150200.5.8.1 * tomcat10-embed-10.1.18-150200.5.8.1 * tomcat10-admin-webapps-10.1.18-150200.5.8.1 * tomcat10-docs-webapp-10.1.18-150200.5.8.1 * tomcat10-10.1.18-150200.5.8.1 * tomcat10-jsvc-10.1.18-150200.5.8.1 * tomcat10-lib-10.1.18-150200.5.8.1 * tomcat10-webapps-10.1.18-150200.5.8.1 * Web and Scripting Module 15-SP5 (noarch) * tomcat10-el-5_0-api-10.1.18-150200.5.8.1 * tomcat10-jsp-3_1-api-10.1.18-150200.5.8.1 * tomcat10-servlet-6_0-api-10.1.18-150200.5.8.1 * tomcat10-admin-webapps-10.1.18-150200.5.8.1 * tomcat10-10.1.18-150200.5.8.1 * tomcat10-lib-10.1.18-150200.5.8.1 * tomcat10-webapps-10.1.18-150200.5.8.1

References

* bsc#1217649

Cross-

* CVE-2023-46589

CVSS scores:

* CVE-2023-46589 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

* CVE-2023-46589 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Affected Products:

* openSUSE Leap 15.5

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

* Web and Scripting Module 15-SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-46589.html

* https://bugzilla.suse.com/show_bug.cgi?id=1217649

Severity
Announcement ID: SUSE-SU-2024:0208-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo