Debian Linux Distribution

Find the information you need for your favorite open source distribution .



# Security update for webkit2gtk3

Announcement ID: SUSE-SU-2024:0548-1  
Rating: important  
References:

  * bsc#1219113
  * bsc#1219604

  
Cross-References:

  * CVE-2014-1745
  * CVE-2023-40414
  * CVE-2023-42833
  * CVE-2024-23206
  * CVE-2024-23213
  * CVE-2024-23222

  
CVSS scores:

  * CVE-2023-40414 ( SUSE ):  7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-40414 ( NVD ):  9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
  * CVE-2023-42833 ( SUSE ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-42833 ( NVD ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2024-23206 ( SUSE ):  6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
  * CVE-2024-23206 ( NVD ):  6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
  * CVE-2024-23213 ( SUSE ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2024-23213 ( NVD ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2024-23222 ( SUSE ):  7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2024-23222 ( NVD ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

  
Affected Products:

  * Basesystem Module 15-SP5
  * Desktop Applications Module 15-SP5
  * Development Tools Module 15-SP5
  * openSUSE Leap 15.4
  * openSUSE Leap 15.5
  * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4
  * SUSE Linux Enterprise Desktop 15 SP5
  * SUSE Linux Enterprise High Performance Computing 15 SP4
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4
  * SUSE Linux Enterprise Real Time 15 SP5
  * SUSE Linux Enterprise Server 15 SP4
  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5
  * SUSE Manager Proxy 4.3
  * SUSE Manager Retail Branch Server 4.3
  * SUSE Manager Server 4.3

  
  
An update that solves six vulnerabilities can now be installed.

## Description:

This update for webkit2gtk3 fixes the following issues:

Update to version 2.42.5 (bsc#1219604):

  * CVE-2024-23222: Fixed processing maliciously crafted web content that may
    have led to arbitrary code execution (bsc#1219113).
  * CVE-2024-23206: Fixed fingerprint user via maliciously crafted webpages
    (bsc#1219604).
  * CVE-2024-23213: Fixed processing web content that may have led to arbitrary
    code execution (bsc#1219604).
  * CVE-2023-40414: Fixed processing web content that may have led to arbitrary
    code execution (bsc#1219604).
  * CVE-2014-1745: Fixed denial-of-service or potentially disclose memory
    contents while processing maliciously crafted files (bsc#1219604).
  * CVE-2023-42833: Fixed processing web content that may have led to arbitrary
    code execution (bsc#1219604).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2024-548=1

  * openSUSE Leap 15.5  
    zypper in -t patch openSUSE-SLE-15.5-2024-548=1

  * Basesystem Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2024-548=1

  * Desktop Applications Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-548=1

  * Development Tools Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP5-2024-548=1

  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-548=1

  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-548=1

  * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4  
    zypper in -t patch SUSE-SLE-Product-SLED-15-SP4-LTSS-2024-548=1

  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-548=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP4  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP4-2024-548=1

  * SUSE Manager Proxy 4.3  
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-548=1

  * SUSE Manager Retail Branch Server 4.3  
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-
Server-4.3-2024-548=1

  * SUSE Manager Server 4.3  
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-548=1

## Package List:

  * openSUSE Leap 15.4 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-minibrowser-2.42.5-150400.4.75.1
    * webkit-jsc-6.0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit-6_0-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * typelib-1_0-WebKitWebProcessExtension-6_0-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-minibrowser-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-minibrowser-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-6_0-2.42.5-150400.4.75.1
    * webkit2gtk4-minibrowser-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-minibrowser-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * webkit-jsc-4.1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit-jsc-4.1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * webkit-jsc-4-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * webkit-jsc-6.0-2.42.5-150400.4.75.1
    * webkit2gtk3-minibrowser-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
    * webkit-jsc-4-debuginfo-2.42.5-150400.4.75.1
  * openSUSE Leap 15.4 (x86_64)
    * libjavascriptcoregtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-32bit-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-32bit-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-32bit-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-32bit-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-32bit-2.42.5-150400.4.75.1
  * openSUSE Leap 15.4 (aarch64_ilp32)
    * libjavascriptcoregtk-4_1-0-64bit-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-64bit-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-64bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-64bit-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-64bit-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-64bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-64bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-64bit-2.42.5-150400.4.75.1
  * openSUSE Leap 15.5 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-minibrowser-2.42.5-150400.4.75.1
    * webkit-jsc-6.0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit-6_0-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * typelib-1_0-WebKitWebProcessExtension-6_0-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-minibrowser-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-minibrowser-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-6_0-2.42.5-150400.4.75.1
    * webkit2gtk4-minibrowser-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-minibrowser-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * webkit-jsc-4.1-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit-jsc-4.1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * webkit-jsc-4-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * webkit-jsc-6.0-2.42.5-150400.4.75.1
    * webkit2gtk3-minibrowser-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
    * webkit-jsc-4-debuginfo-2.42.5-150400.4.75.1
  * openSUSE Leap 15.5 (x86_64)
    * libjavascriptcoregtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-32bit-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-32bit-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-32bit-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-32bit-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-32bit-2.42.5-150400.4.75.1
  * Basesystem Module 15-SP5 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
  * Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
  * Desktop Applications Module 15-SP5 (noarch)
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * Desktop Applications Module 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
  * Development Tools Module 15-SP5 (noarch)
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
  * Development Tools Module 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (aarch64
    x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (aarch64
    x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4 (x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (aarch64 ppc64le s390x
    x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1
    * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (ppc64le x86_64)
    * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-devel-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk4-debugsource-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk3-debugsource-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1
    * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1
    * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
  * SUSE Manager Proxy 4.3 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
  * SUSE Manager Proxy 4.3 (x86_64)
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
  * SUSE Manager Retail Branch Server 4.3 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
  * SUSE Manager Retail Branch Server 4.3 (x86_64)
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1
  * SUSE Manager Server 4.3 (noarch)
    * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1
  * SUSE Manager Server 4.3 (ppc64le s390x x86_64)
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1
    * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1
    * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1
    * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1

## References:

  * https://www.suse.com/security/cve/CVE-2014-1745.html
  * https://www.suse.com/security/cve/CVE-2023-40414.html
  * https://www.suse.com/security/cve/CVE-2023-42833.html
  * https://www.suse.com/security/cve/CVE-2024-23206.html
  * https://www.suse.com/security/cve/CVE-2024-23213.html
  * https://www.suse.com/security/cve/CVE-2024-23222.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1219113
  * https://bugzilla.suse.com/show_bug.cgi?id=1219604

SUSE: 2024:0548-1 important: webkit2gtk3

February 20, 2024
* bsc#1219113 * bsc#1219604 Cross-References: * CVE-2014-1745

Summary

## This update for webkit2gtk3 fixes the following issues: Update to version 2.42.5 (bsc#1219604): * CVE-2024-23222: Fixed processing maliciously crafted web content that may have led to arbitrary code execution (bsc#1219113). * CVE-2024-23206: Fixed fingerprint user via maliciously crafted webpages (bsc#1219604). * CVE-2024-23213: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). * CVE-2023-40414: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). * CVE-2014-1745: Fixed denial-of-service or potentially disclose memory contents while processing maliciously crafted files (bsc#1219604). * CVE-2023-42833: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2024-548=1 * openSUSE Leap 15.5 zypper in -t patch openSUSE-SLE-15.5-2024-548=1 * Basesystem Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2024-548=1 * Desktop Applications Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-548=1 * Development Tools Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP5-2024-548=1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-548=1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-548=1 * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4 zypper in -t patch SUSE-SLE-Product-SLED-15-SP4-LTSS-2024-548=1 * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 zypper in -t patch SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-548=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP4 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP4-2024-548=1 * SUSE Manager Proxy 4.3 zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-548=1 * SUSE Manager Retail Branch Server 4.3 zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch- Server-4.3-2024-548=1 * SUSE Manager Server 4.3 zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-548=1 ## Package List: * openSUSE Leap 15.4 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-minibrowser-2.42.5-150400.4.75.1 * webkit-jsc-6.0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit-6_0-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * typelib-1_0-WebKitWebProcessExtension-6_0-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-minibrowser-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-minibrowser-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-6_0-2.42.5-150400.4.75.1 * webkit2gtk4-minibrowser-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-minibrowser-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * webkit-jsc-4.1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit-jsc-4.1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * webkit-jsc-4-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * webkit-jsc-6.0-2.42.5-150400.4.75.1 * webkit2gtk3-minibrowser-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * webkit-jsc-4-debuginfo-2.42.5-150400.4.75.1 * openSUSE Leap 15.4 (x86_64) * libjavascriptcoregtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-32bit-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-32bit-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-32bit-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-32bit-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-32bit-2.42.5-150400.4.75.1 * openSUSE Leap 15.4 (aarch64_ilp32) * libjavascriptcoregtk-4_1-0-64bit-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-64bit-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-64bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-64bit-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-64bit-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-64bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-64bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-64bit-2.42.5-150400.4.75.1 * openSUSE Leap 15.5 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-minibrowser-2.42.5-150400.4.75.1 * webkit-jsc-6.0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit-6_0-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * typelib-1_0-WebKitWebProcessExtension-6_0-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-minibrowser-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-minibrowser-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-6_0-2.42.5-150400.4.75.1 * webkit2gtk4-minibrowser-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-minibrowser-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * webkit-jsc-4.1-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit-jsc-4.1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * webkit-jsc-4-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * webkit-jsc-6.0-2.42.5-150400.4.75.1 * webkit2gtk3-minibrowser-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * webkit-jsc-4-debuginfo-2.42.5-150400.4.75.1 * openSUSE Leap 15.5 (x86_64) * libjavascriptcoregtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-32bit-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-32bit-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-32bit-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-32bit-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-32bit-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-32bit-2.42.5-150400.4.75.1 * Basesystem Module 15-SP5 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64) * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * Desktop Applications Module 15-SP5 (noarch) * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * Desktop Applications Module 15-SP5 (aarch64 ppc64le s390x x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * Development Tools Module 15-SP5 (noarch) * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * Development Tools Module 15-SP5 (aarch64 ppc64le s390x x86_64) * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (aarch64 x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (aarch64 x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4 (x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (aarch64 ppc64le s390x x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-6.0-lang-2.42.5-150400.4.75.1 * WebKitGTK-4.1-lang-2.42.5-150400.4.75.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (ppc64le x86_64) * libjavascriptcoregtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * webkit2gtk-4_1-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_1-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-devel-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk4-debugsource-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk3-debugsource-2.42.5-150400.4.75.1 * libwebkit2gtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_1-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_1-2.42.5-150400.4.75.1 * libwebkitgtk-6_0-4-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_1-0-2.42.5-150400.4.75.1 * libjavascriptcoregtk-6_0-1-2.42.5-150400.4.75.1 * webkitgtk-6_0-injected-bundles-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * SUSE Manager Proxy 4.3 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * SUSE Manager Proxy 4.3 (x86_64) * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * SUSE Manager Retail Branch Server 4.3 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * SUSE Manager Retail Branch Server 4.3 (x86_64) * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1 * SUSE Manager Server 4.3 (noarch) * WebKitGTK-4.0-lang-2.42.5-150400.4.75.1 * SUSE Manager Server 4.3 (ppc64le s390x x86_64) * libjavascriptcoregtk-4_0-18-debuginfo-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-2.42.5-150400.4.75.1 * libjavascriptcoregtk-4_0-18-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-2.42.5-150400.4.75.1 * typelib-1_0-JavaScriptCore-4_0-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-debugsource-2.42.5-150400.4.75.1 * webkit2gtk3-soup2-devel-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.5-150400.4.75.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.5-150400.4.75.1 * typelib-1_0-WebKit2-4_0-2.42.5-150400.4.75.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.5-150400.4.75.1

References

* bsc#1219113

* bsc#1219604

Cross-

* CVE-2014-1745

* CVE-2023-40414

* CVE-2023-42833

* CVE-2024-23206

* CVE-2024-23213

* CVE-2024-23222

CVSS scores:

* CVE-2023-40414 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-40414 ( NVD ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

* CVE-2023-42833 ( SUSE ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-42833 ( NVD ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2024-23206 ( SUSE ): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

* CVE-2024-23206 ( NVD ): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

* CVE-2024-23213 ( SUSE ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2024-23213 ( NVD ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2024-23222 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2024-23222 ( NVD ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* Basesystem Module 15-SP5

* Desktop Applications Module 15-SP5

* Development Tools Module 15-SP5

* openSUSE Leap 15.4

* openSUSE Leap 15.5

* SUSE Linux Enterprise Desktop 15 SP4 LTSS 15-SP4

* SUSE Linux Enterprise Desktop 15 SP5

* SUSE Linux Enterprise High Performance Computing 15 SP4

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP4

* SUSE Linux Enterprise Real Time 15 SP5

* SUSE Linux Enterprise Server 15 SP4

* SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP4

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

* SUSE Manager Proxy 4.3

* SUSE Manager Retail Branch Server 4.3

* SUSE Manager Server 4.3

An update that solves six vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2014-1745.html

* https://www.suse.com/security/cve/CVE-2023-40414.html

* https://www.suse.com/security/cve/CVE-2023-42833.html

* https://www.suse.com/security/cve/CVE-2024-23206.html

* https://www.suse.com/security/cve/CVE-2024-23213.html

* https://www.suse.com/security/cve/CVE-2024-23222.html

* https://bugzilla.suse.com/show_bug.cgi?id=1219113

* https://bugzilla.suse.com/show_bug.cgi?id=1219604

Severity
Announcement ID: SUSE-SU-2024:0548-1
Rating: important

Related News