Ubuntu 1040-1: Django vulnerabilities

    Date06 Jan 2011
    CategoryUbuntu
    39
    Posted ByLinuxSecurity Advisories
    Adam Baldwin discovered that Django did not properly validate query string lookups. This could be exploited to provide an information leak to an attacker with admin privilieges. (CVE-2010-4534)
    ===========================================================
    Ubuntu Security Notice USN-1040-1          January 07, 2011
    python-django vulnerabilities
    CVE-2010-4534, CVE-2010-4535
    ===========================================================
    
    A security issue affects the following Ubuntu releases:
    
    Ubuntu 9.10
    Ubuntu 10.04 LTS
    Ubuntu 10.10
    
    This advisory also applies to the corresponding versions of
    Kubuntu, Edubuntu, and Xubuntu.
    
    The problem can be corrected by upgrading your system to the
    following package versions:
    
    Ubuntu 9.10:
      python-django                   1.1.1-1ubuntu1.1
    
    Ubuntu 10.04 LTS:
      python-django                   1.1.1-2ubuntu1.2
    
    Ubuntu 10.10:
      python-django                   1.2.3-1ubuntu0.2.10.10.1
    
    In general, a standard system update will make all the necessary changes.
    
    Details follow:
    
    Adam Baldwin discovered that Django did not properly validate query string
    lookups. This could be exploited to provide an information leak to an
    attacker with admin privilieges. (CVE-2010-4534)
    
    Paul McMillan discovered that Django did not validate the length of the
    token used when generating a password reset. An attacker could exploit
    this to cause a denial of service via resource exhaustion. (CVE-2010-4535)
    
    
    Updated packages for Ubuntu 9.10:
    
      Source archives:
    
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1-1ubuntu1.1.diff.gz
          Size/MD5:    20554 69008b0041f74d261d2dfd833f0cbc71
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1-1ubuntu1.1.dsc
          Size/MD5:     2215 80222eacb212cce9d95bd988313f1f72
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1.orig.tar.gz
          Size/MD5:  5614106 d7839c192e115f9c4dd8777de24dc21c
    
      Architecture independent packages:
    
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django-doc_1.1.1-1ubuntu1.1_all.deb
          Size/MD5:  1528844 e46b0b9ab737be222c70d9e5c0445a31
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1-1ubuntu1.1_all.deb
          Size/MD5:  3869262 679a5d0e5668402d7d019e3a7c73d851
    
    Updated packages for Ubuntu 10.04 LTS:
    
      Source archives:
    
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1-2ubuntu1.2.diff.gz
          Size/MD5:    43848 69baf8e98b78de3762e12023f71d0704
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1-2ubuntu1.2.dsc
          Size/MD5:     2215 d18df1b93b0953664165c15870852145
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1.orig.tar.gz
          Size/MD5:  5614106 d7839c192e115f9c4dd8777de24dc21c
    
      Architecture independent packages:
    
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django-doc_1.1.1-2ubuntu1.2_all.deb
          Size/MD5:  1538222 f962bfdfb7feb43460d2a7124190c4e6
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.1.1-2ubuntu1.2_all.deb
          Size/MD5:  3881736 455508583d9a7aea7f7555ad376824f5
    
    Updated packages for Ubuntu 10.10:
    
      Source archives:
    
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.2.3-1ubuntu0.2.10.10.1.debian.tar.gz
          Size/MD5:    21609 391d97abadfcdfcc723b47073359f885
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.2.3-1ubuntu0.2.10.10.1.dsc
          Size/MD5:     2281 336e74a9d11c13359b9470dec5c4b89f
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.2.3.orig.tar.gz
          Size/MD5:  6306760 10bfb5831bcb4d3b1e6298d0e41d6603
    
      Architecture independent packages:
    
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django-doc_1.2.3-1ubuntu0.2.10.10.1_all.deb
          Size/MD5:  1906098 5a1417117c2a2825d93bded7ca785824
        http://security.ubuntu.com/ubuntu/pool/main/p/python-django/python-django_1.2.3-1ubuntu0.2.10.10.1_all.deb
          Size/MD5:  4213194 6cd0e133466c7b624a99c74c3dc56e3c
    
    
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"23","type":"x","order":"1","pct":53.49,"resources":[]},{"id":"88","title":"Should be more technical","votes":"5","type":"x","order":"2","pct":11.63,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"15","type":"x","order":"3","pct":34.88,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.