Ubuntu 3173-1: NVIDIA graphics drivers vulnerability

    Date17 Jan 2017
    106
    Posted ByLinuxSecurity Advisories
    NVIDIA graphics drivers could be made to crash under certain conditions.
    ==========================================================================
    Ubuntu Security Notice USN-3173-1
    January 18, 2017
    
    nvidia-graphics-drivers-304 and nvidia-graphics-drivers-340 vulnerability
    ==========================================================================
    
    A security issue affects these releases of Ubuntu and its derivatives:
    
    - Ubuntu 16.10
    - Ubuntu 16.04 LTS
    - Ubuntu 14.04 LTS
    - Ubuntu 12.04 LTS
    
    Summary:
    
    NVIDIA graphics drivers could be made to crash under certain conditions.
    
    Software Description:
    - nvidia-graphics-drivers-304: NVIDIA binary X.Org driver
    - nvidia-graphics-drivers-340: NVIDIA binary X.Org driver
    
    Details:
    
    It was discovered that the NVIDIA graphics drivers contained a flaw in the
    kernel mode layer. A local attacker could use this issue to cause a denial of
    service.
    
    Update instructions:
    
    The problem can be corrected by updating your system to the following
    package versions:
    
    Ubuntu 16.10:
      nvidia-304                      304.134-0ubuntu0.16.10.1
      nvidia-304-updates              304.134-0ubuntu0.16.10.1
      nvidia-331                      340.101-0ubuntu0.16.10.1
      nvidia-331-updates              340.101-0ubuntu0.16.10.1
      nvidia-340                      340.101-0ubuntu0.16.10.1
      nvidia-340-updates              340.101-0ubuntu0.16.10.1
      nvidia-current                  304.134-0ubuntu0.16.10.1
    
    Ubuntu 16.04 LTS:
      nvidia-304                      304.134-0ubuntu0.16.04.1
      nvidia-304-updates              304.134-0ubuntu0.16.04.1
      nvidia-331                      340.101-0ubuntu0.16.04.1
      nvidia-331-updates              340.101-0ubuntu0.16.04.1
      nvidia-340                      340.101-0ubuntu0.16.04.1
      nvidia-340-updates              340.101-0ubuntu0.16.04.1
      nvidia-current                  304.134-0ubuntu0.16.04.1
    
    Ubuntu 14.04 LTS:
      nvidia-304                      304.134-0ubuntu0.14.04.1
      nvidia-304-updates              304.134-0ubuntu0.14.04.1
      nvidia-331                      340.101-0ubuntu0.14.04.1
      nvidia-331-updates              340.101-0ubuntu0.14.04.1
      nvidia-340                      340.101-0ubuntu0.14.04.1
      nvidia-340-updates              340.101-0ubuntu0.14.04.1
      nvidia-current                  304.134-0ubuntu0.14.04.1
    
    Ubuntu 12.04 LTS:
      nvidia-304                      304.134-0ubuntu0.12.04.1
      nvidia-304-updates              304.134-0ubuntu0.12.04.1
      nvidia-331                      340.101-0ubuntu0.12.04.1
      nvidia-331-updates              340.101-0ubuntu0.12.04.1
      nvidia-340                      340.101-0ubuntu0.12.04.1
      nvidia-340-updates              340.101-0ubuntu0.12.04.1
      nvidia-current                  304.134-0ubuntu0.12.04.1
    
    After a standard system update you need to reboot your computer to make
    all the necessary changes.
    
    References:
      https://www.ubuntu.com/usn/usn-3173-1
      CVE-2016-8826
    
    Package Information:
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/304.134-0ubuntu0.16.10.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.101-0ubuntu0.16.10.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/304.134-0ubuntu0.16.04.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.101-0ubuntu0.16.04.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/304.134-0ubuntu0.14.04.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.101-0ubuntu0.14.04.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/304.134-0ubuntu0.12.04.1
      https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.101-0ubuntu0.12.04.1
    

    LinuxSecurity Poll

    What do you think of the LinuxSecurity Privacy news articles?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/25-what-do-you-think-of-the-linuxsecurity-privacy-news-articles?task=poll.vote&format=json
    25
    radio
    [{"id":"90","title":"Love them!","votes":"48","type":"x","order":"1","pct":88.89,"resources":[]},{"id":"91","title":"I'm indifferent","votes":"4","type":"x","order":"2","pct":7.41,"resources":[]},{"id":"92","title":"Not interested in this topic","votes":"2","type":"x","order":"3","pct":3.7,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.