Ubuntu 3228-1: libevent vulnerabilities

    Date 13 Mar 2017
    171
    Posted By LinuxSecurity Advisories
    Several security issues were fixed in libevent.
    ==========================================================================
    Ubuntu Security Notice USN-3228-1
    March 13, 2017
    
    libevent vulnerabilities
    ==========================================================================
    
    A security issue affects these releases of Ubuntu and its derivatives:
    
    - Ubuntu 16.10
    - Ubuntu 16.04 LTS
    - Ubuntu 14.04 LTS
    - Ubuntu 12.04 LTS
    
    Summary:
    
    Several security issues were fixed in libevent.
    
    Software Description:
    - libevent: Asynchronous event notification library
    
    Details:
    
    Guido Vranken discovered that libevent incorrectly handled memory when
    processing certain data. A remote attacker could possibly use this issue
    with an application that uses libevent to cause a denial of service, or
    possibly execute arbitrary code.
    
    Update instructions:
    
    The problem can be corrected by updating your system to the following
    package versions:
    
    Ubuntu 16.10:
      libevent-2.0-5                  2.0.21-stable-2ubuntu0.16.10.1
    
    Ubuntu 16.04 LTS:
      libevent-2.0-5                  2.0.21-stable-2ubuntu0.16.04.1
    
    Ubuntu 14.04 LTS:
      libevent-2.0-5                  2.0.21-stable-1ubuntu1.14.04.2
    
    Ubuntu 12.04 LTS:
      libevent-2.0-5                  2.0.16-stable-1ubuntu0.2
    
    In general, a standard system update will make all the necessary changes.
    
    References:
      https://www.ubuntu.com/usn/usn-3228-1
      CVE-2016-10195, CVE-2016-10196, CVE-2016-10197
    
    Package Information:
      https://launchpad.net/ubuntu/+source/libevent/2.0.21-stable-2ubuntu0.16.10.1
      https://launchpad.net/ubuntu/+source/libevent/2.0.21-stable-2ubuntu0.16.04.1
      https://launchpad.net/ubuntu/+source/libevent/2.0.21-stable-1ubuntu1.14.04.2
      https://launchpad.net/ubuntu/+source/libevent/2.0.16-stable-1ubuntu0.2
    
    
    

    LinuxSecurity Poll

    If you are using full-disk encryption: are you concerned about the resulting performance hit?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/34-if-you-are-using-full-disk-encryption-are-you-concerned-about-the-resulting-performance-hit?task=poll.vote&format=json
    34
    radio
    [{"id":"120","title":"Yes","votes":"14","type":"x","order":"1","pct":58.33,"resources":[]},{"id":"121","title":"No ","votes":"10","type":"x","order":"2","pct":41.67,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.