Ubuntu 3936-2: AdvanceCOMP vulnerability

    Date23 Apr 2019
    CategoryUbuntu
    2938
    Posted ByLinuxSecurity Advisories
    AdvanceCOMP could be made to run arbitrary code if it opened a specially crafted file.
    ==========================================================================
    Ubuntu Security Notice USN-3936-2
    April 23, 2019
    
    advancecomp vulnerability
    ==========================================================================
    
    A security issue affects these releases of Ubuntu and its derivatives:
    
    - Ubuntu 19.04
    
    Summary:
    
    AdvanceCOMP could be made to run arbitrary code if it opened a
    specially crafted file.
    
    Software Description:
    - advancecomp: collection of recompression utilities
    
    Details:
    
    USN-3936-1 fixed a vulnerability in AdvanceCOMP. This update provides
    the corresponding update for Ubuntu 19.04.
    
    Original advisory details:
    
     It was discovered that AdvanceCOMP incorrectly handled certain PNG
     files. An attacker could possibly use this issue to execute arbitrary
     code.
    
    Update instructions:
    
    The problem can be corrected by updating your system to the following
    package versions:
    
    Ubuntu 19.04:
      advancecomp                     2.1-1ubuntu0.19.04.1
    
    In general, a standard system update will make all the necessary
    changes.
    
    References:
      https://usn.ubuntu.com/usn/usn-3936-2
      https://usn.ubuntu.com/usn/usn-3936-1
      CVE-2019-9210
    
    Package Information:
      https://launchpad.net/ubuntu/+source/advancecomp/2.1-1ubuntu0.19.04.1
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"39","type":"x","order":"1","pct":50,"resources":[]},{"id":"88","title":"Should be more technical","votes":"11","type":"x","order":"2","pct":14.1,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"28","type":"x","order":"3","pct":35.9,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.