Ubuntu 4078-1: OpenLDAP vulnerabilities

    Date30 Jul 2019
    CategoryUbuntu
    1289
    Posted ByLinuxSecurity Advisories
    Several security issues were fixed in OpenLDAP.
    ==========================================================================
    Ubuntu Security Notice USN-4078-1
    July 30, 2019
    
    openldap vulnerabilities
    ==========================================================================
    
    A security issue affects these releases of Ubuntu and its derivatives:
    
    - Ubuntu 19.04
    - Ubuntu 18.04 LTS
    - Ubuntu 16.04 LTS
    
    Summary:
    
    Several security issues were fixed in OpenLDAP.
    
    Software Description:
    - openldap: OpenLDAP utilities
    
    Details:
    
    It was discovered that OpenLDAP incorrectly handled rootDN delegation. A
    database administrator could use this issue to request authorization as an
    identity from another database, contrary to expectations. (CVE-2019-13057)
    
    It was discovered that OpenLDAP incorrectly handled SASL authentication and
    session encryption. After a first SASL bind was completed, it was possible
    to obtain access by performing simple binds, contrary to expectations.
    (CVE-2019-13565)
    
    Update instructions:
    
    The problem can be corrected by updating your system to the following
    package versions:
    
    Ubuntu 19.04:
      slapd                           2.4.47+dfsg-3ubuntu2.1
    
    Ubuntu 18.04 LTS:
      slapd                           2.4.45+dfsg-1ubuntu1.3
    
    Ubuntu 16.04 LTS:
      slapd                           2.4.42+dfsg-2ubuntu3.6
    
    In general, a standard system update will make all the necessary changes.
    
    References:
      https://usn.ubuntu.com/4078-1
      CVE-2019-13057, CVE-2019-13565
    
    Package Information:
      https://launchpad.net/ubuntu/+source/openldap/2.4.47+dfsg-3ubuntu2.1
      https://launchpad.net/ubuntu/+source/openldap/2.4.45+dfsg-1ubuntu1.3
      https://launchpad.net/ubuntu/+source/openldap/2.4.42+dfsg-2ubuntu3.6
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"23","type":"x","order":"1","pct":56.1,"resources":[]},{"id":"88","title":"Should be more technical","votes":"5","type":"x","order":"2","pct":12.2,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"13","type":"x","order":"3","pct":31.71,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.