==========================================================================
Ubuntu Security Notice USN-4677-1
January 05, 2021

p11-kit vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in p11-kit.

Software Description:
- p11-kit: p11-glue utilities

Details:

David Cook discovered that p11-kit incorrectly handled certain memory
operations. An attacker could use this issue to cause p11-kit to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
  libp11-kit0                     0.23.21-2ubuntu0.1
  p11-kit                         0.23.21-2ubuntu0.1
  p11-kit-modules                 0.23.21-2ubuntu0.1

Ubuntu 20.04 LTS:
  libp11-kit0                     0.23.20-1ubuntu0.1
  p11-kit                         0.23.20-1ubuntu0.1
  p11-kit-modules                 0.23.20-1ubuntu0.1

Ubuntu 18.04 LTS:
  libp11-kit0                     0.23.9-2ubuntu0.1
  p11-kit                         0.23.9-2ubuntu0.1
  p11-kit-modules                 0.23.9-2ubuntu0.1

Ubuntu 16.04 LTS:
  libp11-kit0                     0.23.2-5~ubuntu16.04.2
  p11-kit                         0.23.2-5~ubuntu16.04.2
  p11-kit-modules                 0.23.2-5~ubuntu16.04.2

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/4677-1
  CVE-2020-29361, CVE-2020-29362, CVE-2020-29363

Package Information:
  https://launchpad.net/ubuntu/+source/p11-kit/0.23.21-2ubuntu0.1
  https://launchpad.net/ubuntu/+source/p11-kit/0.23.20-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/p11-kit/0.23.9-2ubuntu0.1
  https://launchpad.net/ubuntu/+source/p11-kit/0.23.2-5~ubuntu16.04.2