==========================================================================
Ubuntu Security Notice USN-4689-2
January 11, 2021

linux, linux-aws, linux-aws-5.4, linux-azure, linux-azure-4.15,
linux-azure-5.4, linux-gcp, linux-gcp-5.4, linux-hwe-5.4, linux-hwe-5.8,
linux-oem-5.6, linux-oracle, linux-oracle-5.4 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in the Linux kernel.

Software Description:
- linux: Linux kernel
- linux-aws: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure: Linux kernel for Microsoft Azure Cloud systems
- linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems
- linux-oracle: Linux kernel for Oracle Cloud systems
- linux-hwe-5.8: Linux hardware enablement (HWE) kernel
- linux-oem-5.6: Linux kernel for OEM systems
- linux-aws-5.4: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure-4.15: Linux kernel for Microsoft Azure Cloud systems
- linux-azure-5.4: Linux kernel for Microsoft Azure cloud systems
- linux-gcp-5.4: Linux kernel for Google Cloud Platform (GCP) systems
- linux-hwe-5.4: Linux hardware enablement (HWE) kernel
- linux-oracle-5.4: Linux kernel for Oracle Cloud systems

Details:

USN-4689-1 fixed vulnerabilities in the NVIDIA graphics drivers.
This update provides the corresponding updates for the NVIDIA Linux
DKMS kernel modules.

Original advisory details:

 It was discovered that the NVIDIA GPU display driver for the Linux kernel
 contained a vulnerability that allowed user-mode clients to access legacy
 privileged APIs. A local attacker could use this to cause a denial of
 service or escalate privileges. (CVE-2021-1052)

 It was discovered that the NVIDIA GPU display driver for the Linux kernel
 did not properly validate a pointer received from userspace in some
 situations. A local attacker could use this to cause a denial of service.
 (CVE-2021-1053)

 Xinyuan Lyu discovered that the NVIDIA GPU display driver for the Linux
 kernel did not properly restrict device-level GPU isolation. A local
 attacker could use this to cause a denial of service or possibly expose
 sensitive information. (CVE-2021-1056)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
  linux-image-5.8.0-1015-oracle   5.8.0-1015.16
  linux-image-5.8.0-1016-gcp      5.8.0-1016.17
  linux-image-5.8.0-1017-azure    5.8.0-1017.19
  linux-image-5.8.0-1018-aws      5.8.0-1018.20
  linux-image-5.8.0-36-generic    5.8.0-36.40
  linux-image-5.8.0-36-lowlatency  5.8.0-36.40
  linux-image-aws                 5.8.0.1018.20
  linux-image-azure               5.8.0.1017.17
  linux-image-gcp                 5.8.0.1016.16
  linux-image-generic             5.8.0.36.40
  linux-image-gke                 5.8.0.1016.16
  linux-image-lowlatency          5.8.0.36.40
  linux-image-oracle              5.8.0.1015.15
  linux-image-virtual             5.8.0.36.40

Ubuntu 20.04 LTS:
  linux-image-5.4.0-1034-gcp      5.4.0-1034.37
  linux-image-5.4.0-1035-aws      5.4.0-1035.37
  linux-image-5.4.0-1035-oracle   5.4.0-1035.38
  linux-image-5.4.0-1036-azure    5.4.0-1036.38
  linux-image-5.4.0-60-generic    5.4.0-60.67
  linux-image-5.4.0-60-lowlatency  5.4.0-60.67
  linux-image-5.6.0-1042-oem      5.6.0-1042.46
  linux-image-5.8.0-36-generic    5.8.0-36.40~20.04.1
  linux-image-5.8.0-36-lowlatency  5.8.0-36.40~20.04.1
  linux-image-aws                 5.4.0.1035.36
  linux-image-azure               5.4.0.1036.34
  linux-image-gcp                 5.4.0.1034.43
  linux-image-generic             5.4.0.60.63
  linux-image-generic-hwe-20.04   5.8.0.36.40~20.04.21
  linux-image-lowlatency          5.4.0.60.63
  linux-image-lowlatency-hwe-20.04  5.8.0.36.40~20.04.21
  linux-image-oem                 5.4.0.60.63
  linux-image-oem-20.04           5.6.0.1042.38
  linux-image-oem-osp1            5.4.0.60.63
  linux-image-oracle              5.4.0.1035.32
  linux-image-virtual             5.4.0.60.63
  linux-image-virtual-hwe-20.04   5.8.0.36.40~20.04.21

Ubuntu 18.04 LTS:
  linux-image-4.15.0-1063-oracle  4.15.0-1063.70
  linux-image-4.15.0-1092-aws     4.15.0-1092.98
  linux-image-4.15.0-1104-azure   4.15.0-1104.116
  linux-image-4.15.0-130-generic  4.15.0-130.134
  linux-image-4.15.0-130-lowlatency  4.15.0-130.134
  linux-image-5.4.0-1034-gcp      5.4.0-1034.37~18.04.1
  linux-image-5.4.0-1035-aws      5.4.0-1035.37~18.04.1
  linux-image-5.4.0-1035-oracle   5.4.0-1035.38~18.04.1
  linux-image-5.4.0-1036-azure    5.4.0-1036.38~18.04.1
  linux-image-5.4.0-60-generic    5.4.0-60.67~18.04.1
  linux-image-5.4.0-60-lowlatency  5.4.0-60.67~18.04.1
  linux-image-aws                 5.4.0.1035.20
  linux-image-aws-lts-18.04       4.15.0.1092.94
  linux-image-azure               5.4.0.1036.18
  linux-image-azure-lts-18.04     4.15.0.1104.77
  linux-image-gcp                 5.4.0.1034.22
  linux-image-generic             4.15.0.130.117
  linux-image-generic-hwe-18.04   5.4.0.60.67~18.04.55
  linux-image-lowlatency          4.15.0.130.117
  linux-image-lowlatency-hwe-18.04  5.4.0.60.67~18.04.55
  linux-image-oem                 5.4.0.60.67~18.04.55
  linux-image-oem-osp1            5.4.0.60.67~18.04.55
  linux-image-oracle              5.4.0.1035.38~18.04.19
  linux-image-oracle-lts-18.04    4.15.0.1063.73
  linux-image-virtual             4.15.0.130.117
  linux-image-virtual-hwe-18.04   5.4.0.60.67~18.04.55

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
  https://usn.ubuntu.com/4689-2
  https://usn.ubuntu.com/4689-1
  CVE-2021-1052, CVE-2021-1053, CVE-2021-1056

Package Information:
  https://launchpad.net/ubuntu/+source/linux/5.8.0-36.40
  https://launchpad.net/ubuntu/+source/linux-aws/5.8.0-1018.20
  https://launchpad.net/ubuntu/+source/linux-azure/5.8.0-1017.19
  https://launchpad.net/ubuntu/+source/linux-gcp/5.8.0-1016.17
  https://launchpad.net/ubuntu/+source/linux-oracle/5.8.0-1015.16
  https://launchpad.net/ubuntu/+source/linux/5.4.0-60.67
  https://launchpad.net/ubuntu/+source/linux-aws/5.4.0-1035.37
  https://launchpad.net/ubuntu/+source/linux-azure/5.4.0-1036.38
  https://launchpad.net/ubuntu/+source/linux-gcp/5.4.0-1034.37
  https://launchpad.net/ubuntu/+source/linux-hwe-5.8/5.8.0-36.40~20.04.1
  https://launchpad.net/ubuntu/+source/linux-oem-5.6/5.6.0-1042.46
  https://launchpad.net/ubuntu/+source/linux-oracle/5.4.0-1035.38
  https://launchpad.net/ubuntu/+source/linux/4.15.0-130.134
  https://launchpad.net/ubuntu/+source/linux-aws/4.15.0-1092.98
  https://launchpad.net/ubuntu/+source/linux-aws-5.4/5.4.0-1035.37~18.04.1
  https://launchpad.net/ubuntu/+source/linux-azure-4.15/4.15.0-1104.116
  https://launchpad.net/ubuntu/+source/linux-azure-5.4/5.4.0-1036.38~18.04.1
  https://launchpad.net/ubuntu/+source/linux-gcp-5.4/5.4.0-1034.37~18.04.1
  https://launchpad.net/ubuntu/+source/linux-hwe-5.4/5.4.0-60.67~18.04.1
  https://launchpad.net/ubuntu/+source/linux-oracle/4.15.0-1063.70
  https://launchpad.net/ubuntu/+source/linux-oracle-5.4/5.4.0-1035.38~18.04.1