Ubuntu 5025-2: libsndfile vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5025-2
July 29, 2021

libsndfile vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

libsndfile could be made to crash or run programs as your login if it
opened a specially crafted file.

Software Description:
- libsndfile: Library for reading/writing audio files

Details:

USN-5025-1 fixed a vulnerability in libsndfile. This update provides
the corresponding update for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Original advisory details:

 It was discovered that libsndfile incorrectly handled certain malformed
 files. A remote attacker could use this issue to cause libsndfile to crash,
 resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
  libsndfile1                     1.0.25-10ubuntu0.16.04.3+esm1
  sndfile-programs                1.0.25-10ubuntu0.16.04.3+esm1

Ubuntu 14.04 ESM:
  libsndfile1                     1.0.25-7ubuntu2.2+esm2
  sndfile-programs                1.0.25-7ubuntu2.2+esm2

After a standard system update you need to restart your session to make
all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5025-2
  https://ubuntu.com/security/notices/USN-5025-1
  CVE-2021-3246

Ubuntu 5025-2: libsndfile vulnerability

July 29, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM - Ubuntu 14.04 ESM Summary: libsndfile could be made to crash or run programs as your login if it opened a specially crafted file. Software Description: - libsndfile: Library for reading/writing audio files Details: USN-5025-1 fixed a vulnerability in libsndfile. This update provides the corresponding update for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM. Original advisory details: It was discovered that libsndfile incorrectly handled certain malformed files. A remote attacker could use this issue to cause libsndfile to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: libsndfile1 1.0.25-10ubuntu0.16.04.3+esm1 sndfile-programs 1.0.25-10ubuntu0.16.04.3+esm1 Ubuntu 14.04 ESM: libsndfile1 1.0.25-7ubuntu2.2+esm2 sndfile-programs 1.0.25-7ubuntu2.2+esm2 After a standard system update you need to restart your session to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5025-2

https://ubuntu.com/security/notices/USN-5025-1

CVE-2021-3246

Severity
Ubuntu Security Notice USN-5025-2

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.