Ubuntu 5030-1: Perl DBI module vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5030-1
August 04, 2021

libdbi-perl vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in Perl DBI module.

Software Description:
- libdbi-perl: Perl Database Interface (DBI)

Details:

It was discovered that the Perl DBI module incorrectly opened files outside
of the folder specified in the data source name. A remote attacker could
possibly use this issue to obtain sensitive information. (CVE-2014-10402)

It was discovered that the Perl DBI module incorrectly handled certain long
strings. A local attacker could possibly use this issue to cause the DBI
module to crash, resulting in a denial of service. This issue only affected
Ubuntu 18.04 LTS. (CVE-2020-14393)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  libdbi-perl                     1.643-1ubuntu0.1

Ubuntu 18.04 LTS:
  libdbi-perl                     1.640-1ubuntu0.3

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5030-1
  CVE-2014-10402, CVE-2020-14393

Package Information:
  https://launchpad.net/ubuntu/+source/libdbi-perl/1.643-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/libdbi-perl/1.640-1ubuntu0.3

Ubuntu 5030-1: Perl DBI module vulnerabilities

August 4, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Several security issues were fixed in Perl DBI module. Software Description: - libdbi-perl: Perl Database Interface (DBI) Details: It was discovered that the Perl DBI module incorrectly opened files outside of the folder specified in the data source name. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2014-10402) It was discovered that the Perl DBI module incorrectly handled certain long strings. A local attacker could possibly use this issue to cause the DBI module to crash, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS. (CVE-2020-14393)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 20.04 LTS: libdbi-perl 1.643-1ubuntu0.1 Ubuntu 18.04 LTS: libdbi-perl 1.640-1ubuntu0.3 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5030-1

CVE-2014-10402, CVE-2020-14393

Severity
Ubuntu Security Notice USN-5030-1

Package Information

https://launchpad.net/ubuntu/+source/libdbi-perl/1.643-1ubuntu0.1 https://launchpad.net/ubuntu/+source/libdbi-perl/1.640-1ubuntu0.3

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.