Ubuntu 5051-3: OpenSSL vulnerability

Advisories

==========================================================================
Ubuntu Security Notice USN-5051-3
August 26, 2021

openssl1.0 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS

Summary:

OpenSSL could be made to crash or expose sensitive information
if it received a specially crafted ASN.1 string.

Software Description:
- openssl1.0: Secure Socket Layer (SSL) cryptographic library and tools

Details:

USN-5051-1 fixed a vulnerability in OpenSSL. This update provides the
corresponding update for the openssl1.0 package in Ubuntu 18.04 LTS.

Original advisory details:

 Ingo Schwarze discovered that OpenSSL incorrectly handled certain ASN.1
 strings. A remote attacker could use this issue to cause OpenSSL to crash,
 resulting in a denial of service, or possibly obtain sensitive information.
 (CVE-2021-3712)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
  libssl1.0.0                     1.0.2n-1ubuntu5.7

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5051-3
  https://ubuntu.com/security/notices/USN-5051-1
  CVE-2021-3712

Package Information:
  https://launchpad.net/ubuntu/+source/openssl1.0/1.0.2n-1ubuntu5.7

Ubuntu 5051-3: OpenSSL vulnerability

August 26, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 18.04 LTS Summary: OpenSSL could be made to crash or expose sensitive information if it received a specially crafted ASN.1 string. Software Description: - openssl1.0: Secure Socket Layer (SSL) cryptographic library and tools Details: USN-5051-1 fixed a vulnerability in OpenSSL. This update provides the corresponding update for the openssl1.0 package in Ubuntu 18.04 LTS. Original advisory details: Ingo Schwarze discovered that OpenSSL incorrectly handled certain ASN.1 strings. A remote attacker could use this issue to cause OpenSSL to crash, resulting in a denial of service, or possibly obtain sensitive information. (CVE-2021-3712)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 18.04 LTS: libssl1.0.0 1.0.2n-1ubuntu5.7 After a standard system update you need to reboot your computer to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5051-3

https://ubuntu.com/security/notices/USN-5051-1

CVE-2021-3712

Severity
Ubuntu Security Notice USN-5051-3

Package Information

https://launchpad.net/ubuntu/+source/openssl1.0/1.0.2n-1ubuntu5.7

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.