==========================================================================
Ubuntu Security Notice USN-5069-1
September 08, 2021

libapache2-mod-auth-mellon vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

mod-auth-mellon could be made to redirect to arbitrary sites.

Software Description:
- libapache2-mod-auth-mellon: SAML 2.0 authentication module for Apache

Details:

It was discovered that mod-auth-mellon incorrectly filtered certain URLs.
A remote attacker could possibly use this issue to perform an open redirect
attack.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  libapache2-mod-auth-mellon      0.16.0-1ubuntu0.1

Ubuntu 18.04 LTS:
  libapache2-mod-auth-mellon      0.13.1-1ubuntu0.3

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5069-1
  CVE-2021-3639

Package Information:
  https://launchpad.net/ubuntu/+source/libapache2-mod-auth-mellon/0.16.0-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/libapache2-mod-auth-mellon/0.13.1-1ubuntu0.3