Ubuntu 5079-4: curl regression | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5079-4
September 21, 2021

curl regression
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

USN-5079-2 introduced a regression in curl.

Software Description:
- curl: HTTP, HTTPS, and FTP client and client libraries

Details:

USN-5079-2 fixed vulnerabilities in curl. One of the fixes introduced a
regression. This update fixes the problem.

Original advisory details:

 Patrick Monnerat discovered that curl incorrectly handled upgrades to TLS.
 When receiving certain responses from servers, curl would continue without
 TLS even when the option to require a successful upgrade to TLS was
 specified. (CVE-2021-22946)

 Patrick Monnerat discovered that curl incorrectly handled responses
 received before STARTTLS. A remote attacker could possibly use this issue
 to inject responses and intercept communications. (CVE-2021-22947)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
  curl                            7.47.0-1ubuntu2.19+esm2
  libcurl3                        7.47.0-1ubuntu2.19+esm2
  libcurl3-gnutls                 7.47.0-1ubuntu2.19+esm2
  libcurl3-nss                    7.47.0-1ubuntu2.19+esm2

Ubuntu 14.04 ESM:
  curl                            7.35.0-1ubuntu2.20+esm9
  libcurl3                        7.35.0-1ubuntu2.20+esm9
  libcurl3-gnutls                 7.35.0-1ubuntu2.20+esm9
  libcurl3-nss                    7.35.0-1ubuntu2.20+esm9

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5079-4
  https://ubuntu.com/security/notices/USN-5079-1
  https://launchpad.net/bugs/1944120

Ubuntu 5079-4: curl regression

September 21, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM - Ubuntu 14.04 ESM Summary: USN-5079-2 introduced a regression in curl. Software Description: - curl: HTTP, HTTPS, and FTP client and client libraries Details: USN-5079-2 fixed vulnerabilities in curl. One of the fixes introduced a regression. This update fixes the problem. Original advisory details: Patrick Monnerat discovered that curl incorrectly handled upgrades to TLS. When receiving certain responses from servers, curl would continue without TLS even when the option to require a successful upgrade to TLS was specified. (CVE-2021-22946) Patrick Monnerat discovered that curl incorrectly handled responses received before STARTTLS. A remote attacker could possibly use this issue to inject responses and intercept communications. (CVE-2021-22947)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: curl 7.47.0-1ubuntu2.19+esm2 libcurl3 7.47.0-1ubuntu2.19+esm2 libcurl3-gnutls 7.47.0-1ubuntu2.19+esm2 libcurl3-nss 7.47.0-1ubuntu2.19+esm2 Ubuntu 14.04 ESM: curl 7.35.0-1ubuntu2.20+esm9 libcurl3 7.35.0-1ubuntu2.20+esm9 libcurl3-gnutls 7.35.0-1ubuntu2.20+esm9 libcurl3-nss 7.35.0-1ubuntu2.20+esm9 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5079-4

https://ubuntu.com/security/notices/USN-5079-1

https://launchpad.net/bugs/1944120

Severity
Ubuntu Security Notice USN-5079-4

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.