Ubuntu 5083-1: Python vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5083-1
September 16, 2021

python3.4, python3.5 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

Several security issues were fixed in Python.

Software Description:
- python3.5: An interactive high-level object-oriented language
- python3.4: An interactive high-level object-oriented language

Details:

It was discovered that Python incorrectly handled certain RFCs.
An attacker could possibly use this issue to cause a denial of service.
This issue only affected Ubuntu 16.04 ESM. (CVE-2021-3733)

It was discovered that Python incorrectly handled certain
server responses. An attacker could possibly use this issue to
cause a denial of service. (CVE-2021-3737)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
  python3.5                       3.5.2-2ubuntu0~16.04.13+esm1
  python3.5-minimal               3.5.2-2ubuntu0~16.04.13+esm1

Ubuntu 14.04 ESM:
  python3.4                       3.4.3-1ubuntu1~14.04.7+esm11
  python3.4-minimal               3.4.3-1ubuntu1~14.04.7+esm11

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5083-1
  CVE-2021-3733, CVE-2021-3737

Ubuntu 5083-1: Python vulnerabilities

September 16, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM - Ubuntu 14.04 ESM Summary: Several security issues were fixed in Python. Software Description: - python3.5: An interactive high-level object-oriented language - python3.4: An interactive high-level object-oriented language Details: It was discovered that Python incorrectly handled certain RFCs. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 ESM. (CVE-2021-3733) It was discovered that Python incorrectly handled certain server responses. An attacker could possibly use this issue to cause a denial of service. (CVE-2021-3737)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: python3.5 3.5.2-2ubuntu0~16.04.13+esm1 python3.5-minimal 3.5.2-2ubuntu0~16.04.13+esm1 Ubuntu 14.04 ESM: python3.4 3.4.3-1ubuntu1~14.04.7+esm11 python3.4-minimal 3.4.3-1ubuntu1~14.04.7+esm11 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5083-1

CVE-2021-3733, CVE-2021-3737

Severity
Ubuntu Security Notice USN-5083-1

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.