Ubuntu 5095-1: Apache Commons IO vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5095-1
September 29, 2021

commons-io vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Apache Commons IO could be made to expose sensitive information if it
received a specially crafted input.

Software Description:
- commons-io: Common useful IO related classes

Details:

It was discovered that Apache Commons IO incorrectly handled certain inputs.
An attacker could possibly use this issue to expose sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  libcommons-io-java              2.6-2ubuntu0.20.04.1

Ubuntu 18.04 LTS:
  libcommons-io-java              2.6-2ubuntu0.18.04.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5095-1
  CVE-2021-29425

Package Information:
  https://launchpad.net/ubuntu/+source/commons-io/2.6-2ubuntu0.20.04.1
  https://launchpad.net/ubuntu/+source/commons-io/2.6-2ubuntu0.18.04.1

Ubuntu 5095-1: Apache Commons IO vulnerability

September 29, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Apache Commons IO could be made to expose sensitive information if it received a specially crafted input. Software Description: - commons-io: Common useful IO related classes Details: It was discovered that Apache Commons IO incorrectly handled certain inputs. An attacker could possibly use this issue to expose sensitive information.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 20.04 LTS: libcommons-io-java 2.6-2ubuntu0.20.04.1 Ubuntu 18.04 LTS: libcommons-io-java 2.6-2ubuntu0.18.04.1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5095-1

CVE-2021-29425

Severity
Ubuntu Security Notice USN-5095-1

Package Information

https://launchpad.net/ubuntu/+source/commons-io/2.6-2ubuntu0.20.04.1 https://launchpad.net/ubuntu/+source/commons-io/2.6-2ubuntu0.18.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.