==========================================================================
Ubuntu Security Notice USN-5101-1
October 04, 2021

mongodb vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

MongoDB could be made to crash if it received specially crafted network
traffic.

Software Description:
- mongodb: object/document-oriented database

Details:

It was discovered that MongoDB incorrectly handled certain wire protocol
messages. A remote attacker could possibly use this issue to cause MongoDB
to crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  mongodb                         1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
  mongodb-clients                 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
  mongodb-server                  1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
  mongodb-server-core             1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3

Ubuntu 18.04 LTS:
  mongodb                         1:3.6.3-0ubuntu1.4
  mongodb-clients                 1:3.6.3-0ubuntu1.4
  mongodb-server                  1:3.6.3-0ubuntu1.4
  mongodb-server-core             1:3.6.3-0ubuntu1.4

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5101-1
  CVE-2019-20925

Package Information:

https://launchpad.net/ubuntu/+source/mongodb/1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
  https://launchpad.net/ubuntu/+source/mongodb/1:3.6.3-0ubuntu1.4