Ubuntu 5168-1: NSS vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5168-1
December 01, 2021

nss vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 21.04
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

NSS could be made to crash or run programs if it verified a specially
crafted signature.

Software Description:
- nss: Network Security Service library

Details:

Tavis Ormandy discovered that NSS incorrectly handled verifying DSA/RSA-PSS
signatures. A remote attacker could use this issue to cause NSS to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  libnss3                         2:3.68-1ubuntu1.1

Ubuntu 21.04:
  libnss3                         2:3.61-1ubuntu2.1

Ubuntu 20.04 LTS:
  libnss3                         2:3.49.1-1ubuntu1.6

Ubuntu 18.04 LTS:
  libnss3                         2:3.35-2ubuntu2.13

After a standard system update you need to restart any applications that
use NSS, such as Evolution, to make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5168-1
  CVE-2021-43527

Package Information:
  https://launchpad.net/ubuntu/+source/nss/2:3.68-1ubuntu1.1
  https://launchpad.net/ubuntu/+source/nss/2:3.61-1ubuntu2.1
  https://launchpad.net/ubuntu/+source/nss/2:3.49.1-1ubuntu1.6
  https://launchpad.net/ubuntu/+source/nss/2:3.35-2ubuntu2.13

Ubuntu 5168-1: NSS vulnerability

December 1, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 21.10 - Ubuntu 21.04 - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: NSS could be made to crash or run programs if it verified a specially crafted signature. Software Description: - nss: Network Security Service library Details: Tavis Ormandy discovered that NSS incorrectly handled verifying DSA/RSA-PSS signatures. A remote attacker could use this issue to cause NSS to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 21.10: libnss3 2:3.68-1ubuntu1.1 Ubuntu 21.04: libnss3 2:3.61-1ubuntu2.1 Ubuntu 20.04 LTS: libnss3 2:3.49.1-1ubuntu1.6 Ubuntu 18.04 LTS: libnss3 2:3.35-2ubuntu2.13 After a standard system update you need to restart any applications that use NSS, such as Evolution, to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5168-1

CVE-2021-43527

Severity
Ubuntu Security Notice USN-5168-1

Package Information

https://launchpad.net/ubuntu/+source/nss/2:3.68-1ubuntu1.1 https://launchpad.net/ubuntu/+source/nss/2:3.61-1ubuntu2.1 https://launchpad.net/ubuntu/+source/nss/2:3.49.1-1ubuntu1.6 https://launchpad.net/ubuntu/+source/nss/2:3.35-2ubuntu2.13

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.