==========================================================================
Ubuntu Security Notice USN-5249-1
January 21, 2022

usbview vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

USBView could be made to crash or run programs as an administrator.

Software Description:
- usbview: USB device viewer

Details:

It was discovered that USBView allowed unprivileged users to run usbview as
root. A local attacker could use this vulnerability to gain administrative
privileges or cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  usbview                         2.0-21-g6fe2f4f-2ubuntu0.21.10.3

Ubuntu 20.04 LTS:
  usbview                         2.0-21-g6fe2f4f-2ubuntu0.20.04.1

Ubuntu 18.04 LTS:
  usbview                         2.0-21-g6fe2f4f-1ubuntu1.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5249-1
  CVE-2022-23220

Package Information:
  https://launchpad.net/ubuntu/+source/usbview/2.0-21-g6fe2f4f-2ubuntu0.21.10.3
  https://launchpad.net/ubuntu/+source/usbview/2.0-21-g6fe2f4f-2ubuntu0.20.04.1
  https://launchpad.net/ubuntu/+source/usbview/2.0-21-g6fe2f4f-1ubuntu1.1