==========================================================================
Ubuntu Security Notice USN-5250-2
January 24, 2022

strongswan vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

strongSwan could crash or allow unintended access to network services.

Software Description:
- strongswan: IPsec VPN solution

Details:

USN-5250-1 fixed a vulnerability in strongSwan. This update provides
the corresponding update for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Original advisory details:

 Zhuowei Zhang discovered that stringSwan incorrectly handled EAP
 authentication. A remote attacker could use this issue to cause strongSwan
 to crash, resulting in a denial of service, or possibly bypass client and
 server authentication.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
  libstrongswan                   5.3.5-1ubuntu3.8+esm2
  strongswan                      5.3.5-1ubuntu3.8+esm2

Ubuntu 14.04 ESM:
  libstrongswan                   5.1.2-0ubuntu2.11+esm2
  strongswan                      5.1.2-0ubuntu2.11+esm2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5250-2
  https://ubuntu.com/security/notices/USN-5250-1
  CVE-2021-45079