==========================================================================
Ubuntu Security Notice USN-5257-1
January 31, 2022

ldns vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

ldns could be made to expose sensitive information if it received
a specially crafted input.

Software Description:
- ldns: ldns library for DNS programming

Details:

It was discovered that ldns incorrectly handled certain inputs.
An attacker could possibly use this issue to expose sensitive information.
(CVE-2020-19860, CVE-2020-19861)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
  libldns2                        1.7.0-3ubuntu4.1

Ubuntu 16.04 ESM:
  libldns1                        1.6.17-8ubuntu0.1+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5257-1
  CVE-2020-19860, CVE-2020-19861

Package Information:
  https://launchpad.net/ubuntu/+source/ldns/1.7.0-3ubuntu4.1