==========================================================================
Ubuntu Security Notice USN-5284-1
February 14, 2022

firefox vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Firefox could be made to crash or run programs as your login if it
opened a malicious website.

Software Description:
- firefox: Mozilla Open Source web browser

Details:

Multiple security issues were discovered in Firefox. If a user were
tricked into opening a specially crafted website, an attacker could
potentially exploit these to cause a denial of service, bypass security
restrictions, obtain sensitive information, or execute arbitrary code.
(CVE-2022-0511, CVE-2022-22755, CVE-2022-22759, CVE-2022-22760,
CVE-2022-22761, CVE-2022-22764)

It was discovered that extensions of a particular type could auto-update
themselves and bypass the prompt that requests permissions. If a user
were tricked into installing a specially crafted extension, an attacker
could potentially exploit this to bypass security restrictions.
(CVE-2022-22754)

It was discovered that dragging and dropping an image into a folder could
result in it being marked as executable. If a user were tricked into
dragging and dropping a specially crafted image, an attacker could
potentially exploit this to execute arbitrary code. (CVE-2022-22756)

It was discovered that Remote Agent, used in WebDriver, did not validate
Host or Origin headers. If a user were tricked into opening a specially
crafted website with WebDriver enabled, an attacker could potentially
exploit this to connect back to the user's browser in order to control
it. (CVE-2022-22757)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
   firefox                         97.0+build2-0ubuntu0.21.10.1

Ubuntu 20.04 LTS:
   firefox                         97.0+build2-0ubuntu0.20.04.1

Ubuntu 18.04 LTS:
   firefox                         97.0+build2-0ubuntu0.18.04.1

After a standard system update you need to restart Firefox to make
all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5284-1
   CVE-2022-0511, CVE-2022-22754, CVE-2022-22755, CVE-2022-22756,
   CVE-2022-22757, CVE-2022-22759, CVE-2022-22760, CVE-2022-22761,
   CVE-2022-22764

Package Information:
   https://launchpad.net/ubuntu/+source/firefox/97.0+build2-0ubuntu0.21.10.1
   https://launchpad.net/ubuntu/+source/firefox/97.0+build2-0ubuntu0.20.04.1
   https://launchpad.net/ubuntu/+source/firefox/97.0+build2-0ubuntu0.18.04.1