==========================================================================
Ubuntu Security Notice USN-5293-1
February 21, 2022

c3p0 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

c3p0 could be made to crash if it opened a specially crafted file.

Software Description:
- c3p0: JDBC Connection pooling library

Details:

Aaron Massey discovered that c3p0 could be made to crash when
parsing certain input. An attacker able to modify the application's
XML configuration file could cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  libc3p0-java                    0.9.1.2-10ubuntu0.21.10.1

Ubuntu 20.04 LTS:
  libc3p0-java                    0.9.1.2-10ubuntu0.20.04.1

Ubuntu 18.04 LTS:
  libc3p0-java                    0.9.1.2-9+deb8u1ubuntu0.18.04.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5293-1
  CVE-2019-5427

Package Information:
  https://launchpad.net/ubuntu/+source/c3p0/0.9.1.2-10ubuntu0.21.10.1
  https://launchpad.net/ubuntu/+source/c3p0/0.9.1.2-10ubuntu0.20.04.1
  https://launchpad.net/ubuntu/+source/c3p0/0.9.1.2-9+deb8u1ubuntu0.18.04.1