==========================================================================
Ubuntu Security Notice USN-5323-1
March 14, 2022

nbd vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in NBD.

Software Description:
- nbd: Network Block Device protocol

Details:

It was discovered that NBD incorrectly handled name length fields. A remote
attacker could use this issue to cause NBD to crash, resulting in a denial
of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  nbd-server                      1:3.21-1ubuntu0.1

Ubuntu 20.04 LTS:
  nbd-server                      1:3.20-1ubuntu0.1

Ubuntu 18.04 LTS:
  nbd-server                      1:3.16.2-1ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5323-1
  CVE-2022-26495, CVE-2022-26496

Package Information:
  https://launchpad.net/ubuntu/+source/nbd/1:3.21-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/nbd/1:3.20-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/nbd/1:3.16.2-1ubuntu0.2