Ubuntu 5376-1: Git vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5376-1
April 12, 2022

git vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Git could be made to run arbitrary commands in platforms with multiple users
support.

Software Description:
- git: fast, scalable, distributed revision control system

Details:

俞晨东 discovered that Git incorrectly handled certain repository paths
in platforms with multiple users support. An attacker could possibly use
this issue to run arbitrary commands.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  git                             1:2.32.0-1ubuntu1.1

Ubuntu 20.04 LTS:
  git                             1:2.25.1-1ubuntu3.3

Ubuntu 18.04 LTS:
  git                             1:2.17.1-1ubuntu0.10

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5376-1
  CVE-2022-24765

Package Information:
  https://launchpad.net/ubuntu/+source/git/1:2.32.0-1ubuntu1.1
  https://launchpad.net/ubuntu/+source/git/1:2.25.1-1ubuntu3.3
  https://launchpad.net/ubuntu/+source/git/1:2.17.1-1ubuntu0.10

Ubuntu 5376-1: Git vulnerability

April 12, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 21.10 - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Git could be made to run arbitrary commands in platforms with multiple users support. Software Description: - git: fast, scalable, distributed revision control system Details: 俞晨东 discovered that Git incorrectly handled certain repository paths in platforms with multiple users support. An attacker could possibly use this issue to run arbitrary commands.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 21.10: git 1:2.32.0-1ubuntu1.1 Ubuntu 20.04 LTS: git 1:2.25.1-1ubuntu3.3 Ubuntu 18.04 LTS: git 1:2.17.1-1ubuntu0.10 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5376-1

CVE-2022-24765

Severity
Ubuntu Security Notice USN-5376-1

Package Information

https://launchpad.net/ubuntu/+source/git/1:2.32.0-1ubuntu1.1 https://launchpad.net/ubuntu/+source/git/1:2.25.1-1ubuntu3.3 https://launchpad.net/ubuntu/+source/git/1:2.17.1-1ubuntu0.10

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.