Ubuntu 5378-2: XZ Utils vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5378-2
April 13, 2022

xz-utils vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

XZ Utils could be made to overwrite arbitrary files.

Software Description:
- xz-utils: XZ-format compression utilities

Details:

Cleemy Desu Wayo discovered that XZ Utils incorrectly handled certain
filenames. If a user or automated system were tricked into performing
xzgrep operations with specially crafted filenames, a remote attacker could
overwrite arbitrary files.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  xz-utils                        5.2.5-2ubuntu0.1

Ubuntu 20.04 LTS:
  xz-utils                        5.2.4-1ubuntu1.1

Ubuntu 18.04 LTS:
  xz-utils                        5.2.2-1.3ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5378-2
  https://ubuntu.com/security/notices/USN-5378-1
  CVE-2022-1271

Package Information:
  https://launchpad.net/ubuntu/+source/xz-utils/5.2.5-2ubuntu0.1
  https://launchpad.net/ubuntu/+source/xz-utils/5.2.4-1ubuntu1.1
  https://launchpad.net/ubuntu/+source/xz-utils/5.2.2-1.3ubuntu0.1

Ubuntu 5378-2: XZ Utils vulnerability

April 13, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 21.10 - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: XZ Utils could be made to overwrite arbitrary files. Software Description: - xz-utils: XZ-format compression utilities Details: Cleemy Desu Wayo discovered that XZ Utils incorrectly handled certain filenames. If a user or automated system were tricked into performing xzgrep operations with specially crafted filenames, a remote attacker could overwrite arbitrary files.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 21.10: xz-utils 5.2.5-2ubuntu0.1 Ubuntu 20.04 LTS: xz-utils 5.2.4-1ubuntu1.1 Ubuntu 18.04 LTS: xz-utils 5.2.2-1.3ubuntu0.1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5378-2

https://ubuntu.com/security/notices/USN-5378-1

CVE-2022-1271

Severity
Ubuntu Security Notice USN-5378-2

Package Information

https://launchpad.net/ubuntu/+source/xz-utils/5.2.5-2ubuntu0.1 https://launchpad.net/ubuntu/+source/xz-utils/5.2.4-1ubuntu1.1 https://launchpad.net/ubuntu/+source/xz-utils/5.2.2-1.3ubuntu0.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.