Ubuntu 5494-1: SpiderMonkey JavaScript Library vulnerabilities | Li...

Advisories

==========================================================================
Ubuntu Security Notice USN-5494-1
June 27, 2022

mozjs91 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS

Summary:

Several security issues were fixed in SpiderMonkey JavaScript Library.

Software Description:
- mozjs91: SpiderMonkey JavaScript library

Details:

It was discovered that SpiderMonkey JavaScript Library incorrectly
generated certain assembly code. An remote attacker could
possibly use this issue to cause a crash or expose sensitive
information. (CVE-2022-28285)

It was discovered that SpiderMonkey JavaScript Library incorrectly
generated certain assembly code. An remote attacker could
possibly use this issue to cause a crash. (CVE-2022-31740)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  libmozjs-91-0                   91.10.0-0ubuntu1

After a standard system update you need to restart any application that use
SpiderMonkey JavaScript Library to make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5494-1
  CVE-2022-28285, CVE-2022-31740, https://launchpad.net/bugs/1976260, https://launchpad.net/bugs/1978961

Package Information:
  https://launchpad.net/ubuntu/+source/mozjs91/91.10.0-0ubuntu1

Ubuntu 5494-1: SpiderMonkey JavaScript Library vulnerabilities

June 27, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS Summary: Several security issues were fixed in SpiderMonkey JavaScript Library. Software Description: - mozjs91: SpiderMonkey JavaScript library Details: It was discovered that SpiderMonkey JavaScript Library incorrectly generated certain assembly code. An remote attacker could possibly use this issue to cause a crash or expose sensitive information. (CVE-2022-28285) It was discovered that SpiderMonkey JavaScript Library incorrectly generated certain assembly code. An remote attacker could possibly use this issue to cause a crash. (CVE-2022-31740)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: libmozjs-91-0 91.10.0-0ubuntu1 After a standard system update you need to restart any application that use SpiderMonkey JavaScript Library to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5494-1

CVE-2022-28285, CVE-2022-31740, https://launchpad.net/bugs/1976260, https://launchpad.net/bugs/1978961

Severity
Ubuntu Security Notice USN-5494-1

Package Information

https://launchpad.net/ubuntu/+source/mozjs91/91.10.0-0ubuntu1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.