Ubuntu 5532-1: Bottle vulnerability

Advisories

==========================================================================
Ubuntu Security Notice USN-5532-1
July 26, 2022

python-bottle vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Bottle could be made to leak sensitive information if it received a specially
crafted request.

Software Description:
- python-bottle: fast and simple WSGI-framework for Python

Details:

It was discovered that Bottle incorrectly handled errors during early request 
binding. An attacker could possibly use this issue to disclose sensitve 
information. (CVE-2022-31799)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  python3-bottle                  0.12.19-1+deb11u1build0.22.04.1

Ubuntu 20.04 LTS:
  python3-bottle                  0.12.15-2.1ubuntu0.2

Ubuntu 18.04 LTS:
  python-bottle                   0.12.13-1ubuntu0.2
  python3-bottle                  0.12.13-1ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5532-1
  CVE-2022-31799

Package Information:
  https://launchpad.net/ubuntu/+source/python-bottle/0.12.19-1+deb11u1build0.22.04.1
  https://launchpad.net/ubuntu/+source/python-bottle/0.12.15-2.1ubuntu0.2
  https://launchpad.net/ubuntu/+source/python-bottle/0.12.13-1ubuntu0.2

Ubuntu 5532-1: Bottle vulnerability

July 26, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Bottle could be made to leak sensitive information if it received a specially crafted request. Software Description: - python-bottle: fast and simple WSGI-framework for Python Details: It was discovered that Bottle incorrectly handled errors during early request binding. An attacker could possibly use this issue to disclose sensitve information. (CVE-2022-31799)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: python3-bottle 0.12.19-1+deb11u1build0.22.04.1 Ubuntu 20.04 LTS: python3-bottle 0.12.15-2.1ubuntu0.2 Ubuntu 18.04 LTS: python-bottle 0.12.13-1ubuntu0.2 python3-bottle 0.12.13-1ubuntu0.2 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5532-1

CVE-2022-31799

Severity
Ubuntu Security Notice USN-5532-1

Package Information

https://launchpad.net/ubuntu/+source/python-bottle/0.12.19-1+deb11u1build0.22.04.1 https://launchpad.net/ubuntu/+source/python-bottle/0.12.15-2.1ubuntu0.2 https://launchpad.net/ubuntu/+source/python-bottle/0.12.13-1ubuntu0.2

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.