Ubuntu 5543-1: Net-SNMP vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5543-1
August 01, 2022

net-snmp vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in Net-SNMP.

Software Description:
- net-snmp: SNMP (Simple Network Management Protocol) server and applications

Details:

Yu Zhang and Nanyu Zhong discovered that Net-SNMP incorrectly handled
memory operations when processing certain requests. A remote attacker could
use this issue to cause Net-SNMP to crash, resulting in a denial of
service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  libsnmp-perl                    5.9.1+dfsg-1ubuntu2.2
  libsnmp40                       5.9.1+dfsg-1ubuntu2.2
  snmp                            5.9.1+dfsg-1ubuntu2.2
  snmpd                           5.9.1+dfsg-1ubuntu2.2

Ubuntu 20.04 LTS:
  libsnmp-perl                    5.8+dfsg-2ubuntu2.4
  libsnmp35                       5.8+dfsg-2ubuntu2.4
  snmp                            5.8+dfsg-2ubuntu2.4
  snmpd                           5.8+dfsg-2ubuntu2.4

Ubuntu 18.04 LTS:
  libsnmp-perl                    5.7.3+dfsg-1.8ubuntu3.7
  libsnmp30                       5.7.3+dfsg-1.8ubuntu3.7
  snmp                            5.7.3+dfsg-1.8ubuntu3.7
  snmpd                           5.7.3+dfsg-1.8ubuntu3.7

After a standard system update you need to restart snmpd to make all the
necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5543-1
  CVE-2022-24805, CVE-2022-24806, CVE-2022-24807, CVE-2022-24808,
  CVE-2022-24809, CVE-2022-24810

Package Information:
  https://launchpad.net/ubuntu/+source/net-snmp/5.9.1+dfsg-1ubuntu2.2
  https://launchpad.net/ubuntu/+source/net-snmp/5.8+dfsg-2ubuntu2.4
  https://launchpad.net/ubuntu/+source/net-snmp/5.7.3+dfsg-1.8ubuntu3.7

Ubuntu 5543-1: Net-SNMP vulnerabilities

August 1, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Several security issues were fixed in Net-SNMP. Software Description: - net-snmp: SNMP (Simple Network Management Protocol) server and applications Details: Yu Zhang and Nanyu Zhong discovered that Net-SNMP incorrectly handled memory operations when processing certain requests. A remote attacker could use this issue to cause Net-SNMP to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: libsnmp-perl 5.9.1+dfsg-1ubuntu2.2 libsnmp40 5.9.1+dfsg-1ubuntu2.2 snmp 5.9.1+dfsg-1ubuntu2.2 snmpd 5.9.1+dfsg-1ubuntu2.2 Ubuntu 20.04 LTS: libsnmp-perl 5.8+dfsg-2ubuntu2.4 libsnmp35 5.8+dfsg-2ubuntu2.4 snmp 5.8+dfsg-2ubuntu2.4 snmpd 5.8+dfsg-2ubuntu2.4 Ubuntu 18.04 LTS: libsnmp-perl 5.7.3+dfsg-1.8ubuntu3.7 libsnmp30 5.7.3+dfsg-1.8ubuntu3.7 snmp 5.7.3+dfsg-1.8ubuntu3.7 snmpd 5.7.3+dfsg-1.8ubuntu3.7 After a standard system update you need to restart snmpd to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5543-1

CVE-2022-24805, CVE-2022-24806, CVE-2022-24807, CVE-2022-24808,

CVE-2022-24809, CVE-2022-24810

Severity
Ubuntu Security Notice USN-5543-1

Package Information

https://launchpad.net/ubuntu/+source/net-snmp/5.9.1+dfsg-1ubuntu2.2 https://launchpad.net/ubuntu/+source/net-snmp/5.8+dfsg-2ubuntu2.4 https://launchpad.net/ubuntu/+source/net-snmp/5.7.3+dfsg-1.8ubuntu3.7

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.