Ubuntu 5559-1: Moment.js vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5559-1
August 10, 2022

node-moment vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in Moment.js.

Software Description:
- node-moment: Work with dates in JavaScript (Node.js module)

Details:

It was discovered that Moment.js incorrectly handled certain input paths. An 
attacker could possibly use this issue to cause a loss of integrity by 
changing the correct path to one of their choice. (CVE-2022-24785)

It was discovered that Moment.js incorrectly handled certain input. An attacker 
could possibly use this issue to cause a denial of service. (CVE-2022-31129)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  libjs-moment                    2.29.1+ds-3ubuntu0.2
  node-moment                     2.29.1+ds-3ubuntu0.2

Ubuntu 20.04 LTS:
  libjs-moment                    2.24.0+ds-2ubuntu0.1
  node-moment                     2.24.0+ds-2ubuntu0.1

Ubuntu 18.04 LTS:
  libjs-moment                    2.20.1+ds-1ubuntu0.1
  node-moment                     2.20.1+ds-1ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5559-1
  CVE-2022-24785, CVE-2022-31129

Package Information:
  https://launchpad.net/ubuntu/+source/node-moment/2.29.1+ds-3ubuntu0.2
  https://launchpad.net/ubuntu/+source/node-moment/2.24.0+ds-2ubuntu0.1
  https://launchpad.net/ubuntu/+source/node-moment/2.20.1+ds-1ubuntu0.1

Ubuntu 5559-1: Moment.js vulnerabilities

August 10, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Several security issues were fixed in Moment.js. Software Description: - node-moment: Work with dates in JavaScript (Node.js module) Details: It was discovered that Moment.js incorrectly handled certain input paths. An attacker could possibly use this issue to cause a loss of integrity by changing the correct path to one of their choice. (CVE-2022-24785) It was discovered that Moment.js incorrectly handled certain input. An attacker could possibly use this issue to cause a denial of service. (CVE-2022-31129)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: libjs-moment 2.29.1+ds-3ubuntu0.2 node-moment 2.29.1+ds-3ubuntu0.2 Ubuntu 20.04 LTS: libjs-moment 2.24.0+ds-2ubuntu0.1 node-moment 2.24.0+ds-2ubuntu0.1 Ubuntu 18.04 LTS: libjs-moment 2.20.1+ds-1ubuntu0.1 node-moment 2.20.1+ds-1ubuntu0.1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5559-1

CVE-2022-24785, CVE-2022-31129

Severity
Ubuntu Security Notice USN-5559-1

Package Information

https://launchpad.net/ubuntu/+source/node-moment/2.29.1+ds-3ubuntu0.2 https://launchpad.net/ubuntu/+source/node-moment/2.24.0+ds-2ubuntu0.1 https://launchpad.net/ubuntu/+source/node-moment/2.20.1+ds-1ubuntu0.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.