Ubuntu 5615-1: SQLite vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5615-1
September 15, 2022

sqlite3 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in SQLite.

Software Description:
- sqlite3: C library that implements an SQL database engine

Details:

It was discovered that SQLite incorrectly handled INTERSEC query
processing. An attacker could use this issue to cause SQLite to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2020-35525)

It was discovered that SQLite incorrectly handled ALTER TABLE for views
that have a nested FROM clause.  An attacker could use this issue to cause
SQLite to crash, resulting in a denial of service, or possibly execute
arbitrary code. This issue was only addressed in Ubuntu 20.04 LTS.
(CVE-2020-35527)

It was discovered that SQLite incorrectly handled embedded null characters
when tokenizing certain unicode strings. This issue could result in
incorrect results. This issue only affected Ubuntu 20.04 LTS.
(CVE-2021-20223)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  sqlite3                         3.31.1-4ubuntu0.4

Ubuntu 18.04 LTS:
  sqlite3                         3.22.0-1ubuntu0.6

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5615-1
  CVE-2020-35525, CVE-2020-35527, CVE-2021-20223

Package Information:
  https://launchpad.net/ubuntu/+source/sqlite3/3.31.1-4ubuntu0.4
  https://launchpad.net/ubuntu/+source/sqlite3/3.22.0-1ubuntu0.6

Ubuntu 5615-1: SQLite vulnerabilities

September 15, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: Several security issues were fixed in SQLite. Software Description: - sqlite3: C library that implements an SQL database engine Details: It was discovered that SQLite incorrectly handled INTERSEC query processing. An attacker could use this issue to cause SQLite to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-35525) It was discovered that SQLite incorrectly handled ALTER TABLE for views that have a nested FROM clause. An attacker could use this issue to cause SQLite to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue was only addressed in Ubuntu 20.04 LTS. (CVE-2020-35527) It was discovered that SQLite incorrectly handled embedded null characters when tokenizing certain unicode strings. This issue could result in incorrect results. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-20223)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 20.04 LTS: sqlite3 3.31.1-4ubuntu0.4 Ubuntu 18.04 LTS: sqlite3 3.22.0-1ubuntu0.6 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5615-1

CVE-2020-35525, CVE-2020-35527, CVE-2021-20223

Severity
Ubuntu Security Notice USN-5615-1

Package Information

https://launchpad.net/ubuntu/+source/sqlite3/3.31.1-4ubuntu0.4 https://launchpad.net/ubuntu/+source/sqlite3/3.22.0-1ubuntu0.6

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.