Ubuntu 5646-1: libXi vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5646-1
September 28, 2022

libxi vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in libxi.

Software Description:
- libxi: X11 Input extension library

Details:

Tobias Stoeckmann discovered that libXi did not properly manage memory
when handling X server responses. A remote attacker could use this issue
to cause libXi to crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
   libxi6                          2:1.7.6-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5646-1
   CVE-2016-7945, CVE-2016-7946

Ubuntu 5646-1: libXi vulnerabilities

September 28, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: Several security issues were fixed in libxi. Software Description: - libxi: X11 Input extension library Details: Tobias Stoeckmann discovered that libXi did not properly manage memory when handling X server responses. A remote attacker could use this issue to cause libXi to crash, resulting in a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: libxi6 2:1.7.6-1ubuntu0.1~esm1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5646-1

CVE-2016-7945, CVE-2016-7946

Severity
Ubuntu Security Notice USN-5646-1

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.