Ubuntu 5658-2: DHCP vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5658-2
November 07, 2022

isc-dhcp vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in DHCP.

Software Description:
- isc-dhcp: DHCP server and client

Details:

USN-5658-1 fixed vulnerabilities in DHCP. This update provides
the corresponding updates for Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that DHCP incorrectly handled option reference 
counting. A remote attacker could possibly use this issue to cause DHCP 
servers to crash, resulting in a denial of service. (CVE-2022-2928)

It was discovered that DHCP incorrectly handled certain memory 
operations. A remote attacker could possibly use this issue to cause 
DHCP clients and servers to consume resources, leading to a denial of 
service. (CVE-2022-2929)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
   isc-dhcp-client                  4.3.3-5ubuntu12.10+esm2
   isc-dhcp-server                 4.3.3-5ubuntu12.10+esm2

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5658-2
   https://ubuntu.com/security/notices/USN-5658-1
   CVE-2022-2928, CVE-2022-2929

Ubuntu 5658-2: DHCP vulnerabilities

November 7, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: Several security issues were fixed in DHCP. Software Description: - isc-dhcp: DHCP server and client Details: USN-5658-1 fixed vulnerabilities in DHCP. This update provides the corresponding updates for Ubuntu 16.04 ESM. Original advisory details: It was discovered that DHCP incorrectly handled option reference counting. A remote attacker could possibly use this issue to cause DHCP servers to crash, resulting in a denial of service. (CVE-2022-2928) It was discovered that DHCP incorrectly handled certain memory operations. A remote attacker could possibly use this issue to cause DHCP clients and servers to consume resources, leading to a denial of service. (CVE-2022-2929)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: isc-dhcp-client 4.3.3-5ubuntu12.10+esm2 isc-dhcp-server 4.3.3-5ubuntu12.10+esm2 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5658-2

https://ubuntu.com/security/notices/USN-5658-1

CVE-2022-2928, CVE-2022-2929

Severity
Ubuntu Security Notice USN-5658-2

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.