Ubuntu 5688-1: Libksba vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5688-1
October 19, 2022

libksba vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

Libksba could be made to crash or run programs if it decoded specially
crafted data.

Software Description:
- libksba: X.509 and CMS support library

Details:

It was discovered that an integer overflow could be triggered in Libksba
when decoding certain data. An attacker could use this issue to cause a
denial of service (application crash) or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  libksba8                        1.6.0-2ubuntu0.1

Ubuntu 20.04 LTS:
  libksba8                        1.3.5-2ubuntu0.20.04.1

Ubuntu 18.04 LTS:
  libksba8                        1.3.5-2ubuntu0.18.04.1

Ubuntu 16.04 ESM:
  libksba8                        1.3.3-1ubuntu0.16.04.1+esm1

Ubuntu 14.04 ESM:
  libksba8                        1.3.0-3ubuntu0.14.04.2+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5688-1
  CVE-2022-3515

Package Information:
  https://launchpad.net/ubuntu/+source/libksba/1.6.0-2ubuntu0.1
  https://launchpad.net/ubuntu/+source/libksba/1.3.5-2ubuntu0.20.04.1
  https://launchpad.net/ubuntu/+source/libksba/1.3.5-2ubuntu0.18.04.1

Ubuntu 5688-1: Libksba vulnerability

October 19, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS - Ubuntu 16.04 ESM - Ubuntu 14.04 ESM Summary: Libksba could be made to crash or run programs if it decoded specially crafted data. Software Description: - libksba: X.509 and CMS support library Details: It was discovered that an integer overflow could be triggered in Libksba when decoding certain data. An attacker could use this issue to cause a denial of service (application crash) or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: libksba8 1.6.0-2ubuntu0.1 Ubuntu 20.04 LTS: libksba8 1.3.5-2ubuntu0.20.04.1 Ubuntu 18.04 LTS: libksba8 1.3.5-2ubuntu0.18.04.1 Ubuntu 16.04 ESM: libksba8 1.3.3-1ubuntu0.16.04.1+esm1 Ubuntu 14.04 ESM: libksba8 1.3.0-3ubuntu0.14.04.2+esm1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5688-1

CVE-2022-3515

Severity
Ubuntu Security Notice USN-5688-1

Package Information

https://launchpad.net/ubuntu/+source/libksba/1.6.0-2ubuntu0.1 https://launchpad.net/ubuntu/+source/libksba/1.3.5-2ubuntu0.20.04.1 https://launchpad.net/ubuntu/+source/libksba/1.3.5-2ubuntu0.18.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.