Ubuntu 5688-2: Libksba vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5688-2
October 26, 2022

libksba vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10

Summary:

Libksba could be made to crash or run programs if it decoded specially
crafted data.

Software Description:
- libksba: X.509 and CMS support library

Details:

USN-5688-1 fixed vulnerabilities in Libksba. This update provides
the corresponding update for Ubuntu 22.10.

Original advisory details:

 It was discovered that an integer overflow could be triggered in Libksba
 when decoding certain data. An attacker could use this issue to cause a
 denial of service (application crash) or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
  libksba8                        1.6.0-3ubuntu1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5688-2
  https://ubuntu.com/security/notices/USN-5688-1
  CVE-2022-3515

Package Information:
  https://launchpad.net/ubuntu/+source/libksba/1.6.0-3ubuntu1

Ubuntu 5688-2: Libksba vulnerability

October 26, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.10 Summary: Libksba could be made to crash or run programs if it decoded specially crafted data. Software Description: - libksba: X.509 and CMS support library Details: USN-5688-1 fixed vulnerabilities in Libksba. This update provides the corresponding update for Ubuntu 22.10. Original advisory details: It was discovered that an integer overflow could be triggered in Libksba when decoding certain data. An attacker could use this issue to cause a denial of service (application crash) or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.10: libksba8 1.6.0-3ubuntu1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5688-2

https://ubuntu.com/security/notices/USN-5688-1

CVE-2022-3515

Severity
Ubuntu Security Notice USN-5688-2

Package Information

https://launchpad.net/ubuntu/+source/libksba/1.6.0-3ubuntu1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.