Ubuntu 5690-1: libXdmcp vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5690-1
October 19, 2022

libxdmcp vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

libXdmcp could be made to expose sensitive information.

Software Description:
- libxdmcp: X11 authorisation library (development headers)

Details:

It was discovered that libXdmcp was generating weak session keys.
A local attacker could possibly use this issue to perform a brute
force attack and obtain another user's key.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
   libxdmcp6                       1:1.1.2-1.1ubuntu0.1~esm1

Ubuntu 14.04 ESM:
   libxdmcp6                       1:1.1.1-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5690-1
   CVE-2017-2625

Ubuntu 5690-1: libXdmcp vulnerability

October 19, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM - Ubuntu 14.04 ESM Summary: libXdmcp could be made to expose sensitive information. Software Description: - libxdmcp: X11 authorisation library (development headers) Details: It was discovered that libXdmcp was generating weak session keys. A local attacker could possibly use this issue to perform a brute force attack and obtain another user's key.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM:   libxdmcp6                       1:1.1.2-1.1ubuntu0.1~esm1 Ubuntu 14.04 ESM:   libxdmcp6                       1:1.1.1-1ubuntu0.1~esm1 In general, a standard system update will make all the necessary changes.

References

  https://ubuntu.com/security/notices/USN-5690-1

  CVE-2017-2625

Severity
Ubuntu Security Notice USN-5690-1

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.