Ubuntu 5716-1: SQLite vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5716-1
November 07, 2022

sqlite3 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

SQLite could be made to crash or run programs if it received specially
crafted input.

Software Description:
- sqlite3: C library that implements an SQL database engine

Details:

It was discovered that SQLite incorrectly handled certain long string
arguments. An attacker could use this issue to cause SQLite to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
   libsqlite3-0                    3.37.2-2ubuntu0.1

Ubuntu 20.04 LTS:
   libsqlite3-0                    3.31.1-4ubuntu0.5

Ubuntu 18.04 LTS:
   libsqlite3-0                    3.22.0-1ubuntu0.7

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5716-1
   CVE-2022-35737

Package Information:
   https://launchpad.net/ubuntu/+source/sqlite3/3.37.2-2ubuntu0.1
   https://launchpad.net/ubuntu/+source/sqlite3/3.31.1-4ubuntu0.5
   https://launchpad.net/ubuntu/+source/sqlite3/3.22.0-1ubuntu0.7

Ubuntu 5716-1: SQLite vulnerability

November 7, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: SQLite could be made to crash or run programs if it received specially crafted input. Software Description: - sqlite3: C library that implements an SQL database engine Details: It was discovered that SQLite incorrectly handled certain long string arguments. An attacker could use this issue to cause SQLite to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: libsqlite3-0 3.37.2-2ubuntu0.1 Ubuntu 20.04 LTS: libsqlite3-0 3.31.1-4ubuntu0.5 Ubuntu 18.04 LTS: libsqlite3-0 3.22.0-1ubuntu0.7 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5716-1

CVE-2022-35737

Severity
Ubuntu Security Notice USN-5716-1

Package Information

https://launchpad.net/ubuntu/+source/sqlite3/3.37.2-2ubuntu0.1 https://launchpad.net/ubuntu/+source/sqlite3/3.31.1-4ubuntu0.5 https://launchpad.net/ubuntu/+source/sqlite3/3.22.0-1ubuntu0.7

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.