Ubuntu 5718-1: pixman vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5718-1
November 08, 2022

pixman vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

pixman could be made to crash or run programs if it processed specially
crafted input.

Software Description:
- pixman: pixel-manipulation library for X and cairo

Details:

Maddie Stone discovered that pixman incorrectly handled certain memory
operations. A remote attacker could use this issue to cause pixman to
crash, resulting in a denial of service, or possibly execute arbitrary
code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
   libpixman-1-0                   0.40.0-1ubuntu0.22.10.1

Ubuntu 22.04 LTS:
   libpixman-1-0                   0.40.0-1ubuntu0.22.04.1

Ubuntu 20.04 LTS:
   libpixman-1-0                   0.38.4-0ubuntu2.1

Ubuntu 18.04 LTS:
   libpixman-1-0                   0.34.0-2ubuntu0.1

After a standard system update you need to restart your session to make all
the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5718-1
   CVE-2022-44638

Package Information:
   https://launchpad.net/ubuntu/+source/pixman/0.40.0-1ubuntu0.22.10.1
   https://launchpad.net/ubuntu/+source/pixman/0.40.0-1ubuntu0.22.04.1
   https://launchpad.net/ubuntu/+source/pixman/0.38.4-0ubuntu2.1
   https://launchpad.net/ubuntu/+source/pixman/0.34.0-2ubuntu0.1

Ubuntu 5718-1: pixman vulnerability

November 8, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.10 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: pixman could be made to crash or run programs if it processed specially crafted input. Software Description: - pixman: pixel-manipulation library for X and cairo Details: Maddie Stone discovered that pixman incorrectly handled certain memory operations. A remote attacker could use this issue to cause pixman to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.10: libpixman-1-0 0.40.0-1ubuntu0.22.10.1 Ubuntu 22.04 LTS: libpixman-1-0 0.40.0-1ubuntu0.22.04.1 Ubuntu 20.04 LTS: libpixman-1-0 0.38.4-0ubuntu2.1 Ubuntu 18.04 LTS: libpixman-1-0 0.34.0-2ubuntu0.1 After a standard system update you need to restart your session to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5718-1

CVE-2022-44638

Severity
Ubuntu Security Notice USN-5718-1

Package Information

https://launchpad.net/ubuntu/+source/pixman/0.40.0-1ubuntu0.22.10.1 https://launchpad.net/ubuntu/+source/pixman/0.40.0-1ubuntu0.22.04.1 https://launchpad.net/ubuntu/+source/pixman/0.38.4-0ubuntu2.1 https://launchpad.net/ubuntu/+source/pixman/0.34.0-2ubuntu0.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.