Ubuntu 5777-1: Pillow vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5777-1
December 13, 2022

pillow vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in Pillow.

Software Description:
- pillow: Python Imaging Library

Details:

It was discovered that Pillow incorrectly handled the deletion of temporary
files when using a temporary directory that contains spaces. An attacker 
could
possibly use this issue to delete arbitrary files. This issue only affected
Ubuntu 20.04 LTS. (CVE-2022-24303)

It was discovered that Pillow incorrectly handled the decompression of 
highly
compressed GIF data. An attacker could possibly use this issue to cause 
Pillow
to crash, resulting in a denial of service. (CVE-2022-45198)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
   python3-pil                     9.0.1-1ubuntu0.1

Ubuntu 20.04 LTS:
   python3-pil                     7.0.0-4ubuntu0.7

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5777-1
   CVE-2022-24303, CVE-2022-45198

Package Information:
   https://launchpad.net/ubuntu/+source/pillow/9.0.1-1ubuntu0.1
   https://launchpad.net/ubuntu/+source/pillow/7.0.0-4ubuntu0.7

Ubuntu 5777-1: Pillow vulnerabilities

December 13, 2022
Several security issues were fixed in Pillow.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS Summary: Several security issues were fixed in Pillow. Software Description: - pillow: Python Imaging Library Details: It was discovered that Pillow incorrectly handled the deletion of temporary files when using a temporary directory that contains spaces. An attacker could possibly use this issue to delete arbitrary files. This issue only affected Ubuntu 20.04 LTS. (CVE-2022-24303) It was discovered that Pillow incorrectly handled the decompression of highly compressed GIF data. An attacker could possibly use this issue to cause Pillow to crash, resulting in a denial of service. (CVE-2022-45198)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS:   python3-pil                     9.0.1-1ubuntu0.1 Ubuntu 20.04 LTS:   python3-pil                     7.0.0-4ubuntu0.7 In general, a standard system update will make all the necessary changes.

References

  https://ubuntu.com/security/notices/USN-5777-1

  CVE-2022-24303, CVE-2022-45198

Severity
Ubuntu Security Notice USN-5777-1

Package Information

  https://launchpad.net/ubuntu/+source/pillow/9.0.1-1ubuntu0.1   https://launchpad.net/ubuntu/+source/pillow/7.0.0-4ubuntu0.7

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.